Site Speed - I can NEVER get decent scores

Hey there,

For the life of me, I can never get my speed scores high. (5% of the time it's just image related. I understand the idea of "compression" and the "compression & resizing" but I can never seem to make a dent.

This is a site in development, so I wanted to start implementing good practices early, and hopefully learn something to use in future builds.

Thanks!

  • Dimitris

    Hey there Matt,

    hope you're doing good today! :slight_smile:

    I was checking the shoot******.com website as you hadn't assign any connected website with this thread and I have support access in couple of sites.

    About "compressing and resizing" you can have a read in this awesome blog post by Jenni here:
    https://premium.wpmudev.org/blog/compress-resize-images-wordpress/

    Inspecting the Performance Report in this website, I noticed that there are some images reported that needs compressing, which don't use some thumbnail version but the full size image version.
    Full sized images don't get smushed by default though, so you should activate the "Include my original full-size images" and then bulk smush once again.
    You can even combine this with the "Make a copy of my original images" option. :wink:

    There are also some image thumbnails reported in Performance Report which aren't shown in Smush settings, under the found thumbnail versions.
    This may be caused by some bad coding of these thumbnails. You can try to regenerate all missing thumbnails using a plugin like https://wordpress.org/plugins/regenerate-thumbnails/
    and then re-check images in Media -> WP Smush.

    Let me know how that goes!
    Warm regards,
    Dimitris

  • Matt

    Hey Dimitris!

    I followed your directions! Thanks so much for the advice! This is the first time I've ever seen on of my websites not showing "poor" for "Optimize Images" so I'm really excited about that!

    I'm at 80/100 now on the main site, and was wondering what else I could be doing. The "regenerate thumbnails" , "Make a copy of my original images" , and "Include my original full-size images" all helped tremendously. Is there anything else I could be doing to get that score higher?

    Thanks again for your help. I appreciate it!

  • Dimitris

    Hey there Matt,

    hope you're doing good today! :slight_smile:

    I just went ahead and accessed your website once more.
    This time, I've activate the Browser Caching in HummingBird (simply used the Apache server type and left HB do its thing) and re-run the Performance Report.
    I can now see a total score of 70% and the "Optimize images" score is 85%!

    As you can see for yourself under the "Optimize images" score, there are still some images that need "compressing and resizing" (source: https://premium.wpmudev.org/blog/compress-resize-images-wordpress/)

    Main low score now is the "Improve server response time" though. For that, you should initialize some caching as proposed by HB (probably a plugin and some additional server side caching mechanisms).

    As for raising up the "Remove render blocking resources" part, please have a read of this detailed article from our blog:
    https://premium.wpmudev.org/blog/eliminate-render-blocking-issues-hummingbird/

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.