Site speed slowed

[Hummingbird] Site speed has slowed of late and there are no 'changes' to reflect this -- a little odd. Most pages take near double the time to load for some reason that I can't figure out -- had chat support assistance optimising plugin a few weeks ago, but performance has not improved -- can plugin be further optimised and/or any recommendations to get speed back on track? Thank you kindly :slight_smile:

  • Ash

    Hello Dr48

    If you look at the pagespeed report here: https://developers.google.com/speed/pagespeed/insights/?url=topicthread.com

    You will 10+ second is taken for the issue "Eliminate render-blocking resources". It seems you are loading all the scripts in header. Try to move all scripts and styles one by one in the footer. Please go to Dashboard > Hummingbird > Aset Optimization and for each asset you have option to move to footer.

    You also have some non-minified javascript files, that you can try to minify.

    Let us know if that improves the speed a bit. Have a nice day!

    Cheers,
    Ash

  • Dr48

    Hi Ash,

    Thank you again, and for the help (apologies for the delay) -- I tested asset optimisation (on) again as i have used it previously with some issues; unfortunately I went through and played around with different settings then individually and so forth -- though the issues start when I turned asset optimisation on (or rather activate). All icons, for example, simply turn to boxes throughout. Then regardless when playing with the settings, the home page may show the icons as normal but then the heading may have issues; then next page, it is reversed -- quite the mixup to say the least.

    Is there any other way you may be able to recommend to speed up the site? As for the recommendations on minify, I spoke to support a little while back and was told this was a 'false read' and can happen sometimes (I believe from memory) as they went into cPanel and double-checked why these issues were persisting i.e. they said regardless of the 'fixes' shown all was okay. But...as you can see/tell, the site is still lagging..

    Any suggestions or am I missing something? Would be super great to have the page speed load back up nice and smoothly :slight_smile:

    Thanks Ash :slight_smile:

  • Ash

    Hello Dr48

    When I visit your site in the browser, it doesn't look like slow to me.

    In your situation, I just think of moving files between header and footer. But as I said, it really depends on the files and how they are used. Some files need to be in header, so pushing them into footer will break the site.

    I can take a look and try something, but if you want me to do that, make sure you take a complete backup including database backup of the site (from phpmyadmin would be easier for a quick db backup). So if anything goes wrong, you can restore.

    Also, please enable support access so that I can check Please follow this article to enable support access: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Have a nice day!

    Cheers,
    Ash

  • Dr48

    Hi Ash,

    Thank you so very much -- support access is now granted & site backups are done daily through my host so I can auto-restore should something go wrong (to be safe) -- the biggest issue is when asset optimisation is turned on the header and menu icons are skewed, so just wondering if there is anything else I can do, or consider, that hasn't been already, for the site to run even more smoothly :slight_smile: All suggestion more than welcome!! And a big thank you for your expertise here :smiley:

    Thank you :slight_smile:

  • Nithin

    Hi Dr48,

    Hope you are doing good today. :slight_smile:

    Seems like Hummingbird Asset Optimization was disabled at the moment, so I checked your sites load speed via pingdom test, and could notice the website loads at over 4 seconds:
    https://tools.pingdom.com/#59da724cf5400000

    The above score point that the server is taking 2 seconds to establish a connection.

    I then enabled Hummingbird Asset Optimization, and moved couple of files to footer, and enabled compressing, and uncompressing options for the files etc

    And the site was loading at 3 seconds, and the server was taking 1.5 seconds to establish an initial connection. There seems to be a bit improvement with the speed, please check, and see how that goes.

    However how a website loads entirely depends upon various factors like Server resources, number of plugins installed etc, and the load speed will vary, and depends upon these factors.

    What Hummingbird provides is application level changes, if the server in general is loading slow, there isn't much that Hummingbird could help. Checking with your hosting provider whether there are any scope of improvements regarding the load speed will also help.

    the biggest issue is when asset optimisation is turned on the header and menu icons are skewed, so just wondering if there is anything else I can do, or consider, that hasn't been already, for the site to run even more smoothly

    I could notice that, but I'm afraid, there isn't any easy fix for this. This occurs due to minification, and entirely depends upon your theme on how it honours minification.

    The only way to find out which exact file is causing the issue, is only via Trial, and error method. I was able to notice the files all.css, main-global.cs, main-desktop.css files had to be set to the following to make sure the icons are loading fine:

    The trial & error method steps is more like, in your Asset Optimization page:
    1) Go to the 1st file listed, enable "Compression" option for the 1st file,
    2) Load the frontend, and check whether the homepage layout breaks
    3) If not, you can enable the "Move to Footer" option, and then check the homepage, and see whether the layout breaks.
    4) If the layout breaks this time, you'll have to revert the "Move to Footer" option Save the changes, and move on with next files listed in Asset optimization page, and start with step 1 again.

    You can carry out the above steps, in case you'll have to tweak the files further.

    Regards,
    Nithin

  • Dr48

    Hi Nithin,

    Thanks for this -- Hummingbird wasnt active due to as soon as it's activated regardless of any setting changes the layout breaks ie. Mobile view and Icons, so although you activated asset optimization I had to deactivate again due to this conflict. It seems that although some items you've said can be turned on and moved to footer, it doesn't help the layout issues that occurr as soon as asset optimization is turned on.

    Any thoughts besides asset optimisation that will help with the site load time?

    Big thank you for your help :smiley:

  • Ash

    Hello Dr48

    Any thoughts besides asset optimisation that will help with the site load time?

    You can enable page caching, browser caching and gravatar caching.

    Also, smushing images is a great idea which will improve your loading time. I guess you are already familiar but still here is the link of smush: https://premium.wpmudev.org/project/wp-smush-pro/

    Hope it helps! Please feel free to ask more questions if you have any.

    Have a nice day!

    Cheers,
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.