Site wide text change issue with 3.0

Hi everyone,
So I'm trying to use the "site wide text change" plugin with 3.0 but have run into an issue.

Using the latest version 2.0.1 (6-18-2010 release). When I click "add new" all I get is a prompt at the top that says "your settings have been updated". Nothing else shows up.

Thought is was 3.0 compatible since it's a 6-18-2010 release, am I missing something?

Thanks!