Sitemap 404 error for nginx server

I’m getting a 404 error when clicking on the /sitemap.xml link from SmartCrawl. I checked it and I can see that the sitemap has been properly created and that it’s placed under /wp-content/uploads/sitemap.xml instead of being in /sitemap.xml

I’ve found this ticket on which a fix is suggested consisting in adding a line to nginx.conf file, but I would rather prefer not to have to edit the file. From what I see, your plugin should work without custom NGINX rules.

t works fine on other sites which use NGINX. We need to find out why it’s not working. This website uses Nginx as a reverse proxy to Apache with htaccess enabled.

Can you please help me understand why it’s not working?

  • James Morris
    • WordPress Enthusiast

    Hello Brian

    I hope you are well today.

    This website uses Nginx as a reverse proxy to Apache with htaccess enabled.

    This sounds like a similar configuration to my Plesk Onyx Cloud Server. As you can see from the following link, sitemaps are working quite well in that environment.

    There are no additional defines to my conf files. All defaults. So, there’s definitely something specific to this site that is causing the issue.

    Since you are also using Plesk Onyx, I’m assuming you’re already aware that rules can be defined per site. Do you have any other rules defined in your account for NGINX or Apache?

    Would it be possible to grant me Plesk access to just this one site?

    If so, please visit the Contact page and complete the form with the following information:

    Option: I have a different Question

    Subject: “Attn: James Morris”

    In the Message box, please provide the following:

    – link back to this thread for reference

    – any other relevant urls

    – Hosting Control Panel Login

    Admin username

    Admin password

    Login url

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.