Sitemap not working

I uploaded the directory and files exactly as per instructions:

/all-in-one-seo-pack/ - goes in /wp-content/mu-plugins
all_in_one_seo_pack.php - goes in /wp-content/mu-plugins
simple-sitemaps.php - goes in /wp-content/mu-plugins
sitemap.php - goes in /wp-content

Yes, sitemap.php is in wp-content and not in mu-plugins. Since it is not generating a file named sitemap.xml in the root, I wonder if the error is in my htaccess file?

Instructions said: Add the following to your .htaccess under the line that handles uploaded files:
RewriteRule ^(.*/)?sitemap.xml wp-content/sitemap.php [L]

Here is my .htaccess file content:

--------------------------------
RewriteEngine On
RewriteBase /

#uploaded files
RewriteRule ^(.*/)?files/$ index.php [L]
RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]
RewriteRule ^(.*/)?sitemap.xml wp-content/sitemap.php [L]

# add a trailing slash to /wp-admin
RewriteCond %{REQUEST_URI} ^.*/wp-admin$
RewriteRule ^(.+)$ $1/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule . - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

php_value memory_limit 32M
php_flag display_errors On

<IfModule mod_security.c>
<Files async-upload.php>
SecFilterEngine Off
SecFilterScanPOST Off
</Files>
</IfModule>

Options -MultiViews
ErrorDocument 404 //27480.php

--------------------------------
Any suggestions?