Sites Stop loading after copying course Posts

I just created a multisite. I am testing the tools you have to copy courses to all the multisites I have in one push. I am using the Multisite Content Copier. The copy looks like it finishes up alright and I can confirm there are new entries in the database for the course, but when I try to navigate anywhere after the copy none of my multisites work. It brings down my entire network. I have to go through FTP and remove coursepress for anything to start loading again, and after that I am unable to get coursepress to activate again. It looks to be getting caught in some kind of infinite loop.

I only have the coursepress, multisite content copier and wpmu dev plugins active on the default wordpress theme.

I have granted access on: http://multisite.cgdev.link/

  • Michael Bissett

    Hey @ChooseGrowth! :slight_smile:

    As to this:

    During the course of writing my initial issue, I went back to the my sites to work on it some more. I was finally able to activate coursepress and can see the copy did in fact work. The issue now is why is the entire network down for about 5 minutes when I push an update?

    A few checks come in mind, namely:

    - How much memory is allocated to the site?
    - Is there anything showing up in the server logs around the time that your site was down?
    - If not, then if you were to insert the following into your wp-config.php (replacing any mention of WP_DEBUG that's presently there):

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors',0);

    Does anything show up in debug.log when you try copying, and the network locks up?

    I'm not able to reproduce this behavior over on my own site, copying a course proceeds on without a white screen afterwards.

    On this though:

    Digging even deeper I have found that the Units are getting copied, but the pages inside the units are being left behind. Any thoughts on why that would be happening?

    I am able to reproduce this behavior, we've run into a bug here, which I'll inform the developer of.

    In the meantime though, could have a go at the suggestions I mentioned earlier, so we can narrow down the cause of those white screens on your network?

    Thanks in advance! :slight_smile:

    Kind Regards,
    Michael

  • Black Fox

    To be clear on the issue.

    When I run the copy, the copy goes through with no issue at all.
    Its when I try to navigate to anywhere in the network after the copy that it will not load for awhile.

    After about 5 minutes the sites start loading like normal again.

    I have added the debug code to the wp-config file. I re-ran the copy. I triggered the loading error I have been experiencing. I am not getting any errors in the log file.

    The site I am currently working on is dedicated to Development. There is no data that needs to be saved, but I do need to have these concepts working before I try to implement them on a real site.

    I have left the debug code in the wp-config.php file.

  • Michael Bissett

    Hey @ChooseGrowth,

    Hmm... interesting. While the working out of that bug I mentioned is presently in the developer's hands, I'd like to investigate the cause of this white screen more closely. Could you please send in the following via our secure contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks! :slight_smile:

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @ChooseGrowth! :slight_smile:

    I've tried copying the courses & units from both your main site, as well as your master template site, over to a test site I created, and I didn't see a white screen anywhere in your network (navigating both the front & back end of it).

    I also tried copying a course (with it's units) from your master template site over to your Copy Site 2 subsite, and I didn't see a white screen then either.

    You mentioned your host having issues in your latest email, perhaps this was a host related issue? Are you still able to reproduce this on your end?

    Please advise,
    Michael

  • Black Fox

    The issue was never a white screen. The issue was when a copy happened the site would not load anything for a period of time. When clicking around normally it loads nicely, but after a copy function I would try to go to the sub-site to confirm the copy had happened and the site would just spin. There was never a white screen issue with this, just a period of about 5 minutes after a copy that I couldn't do anything.

    I tested again and can confirm its still having that issue.

  • Michael Bissett

    Hey @ChooseGrowth,

    My apologies for thinking it was a white screen here, but I'm still not seeing any site loading issues when I do a copy of courses & units (didn't run into a issue with any site on the network loading last time either).

    I've tried going to the subsite directly after a copy, and I've also tried going to other sites right after a copy, and I'm seeing it load just fine.

    It's definitely odd that it's going like clockwork for me, yet it's giving you grief when you try doing the same thing. To be on the safe side, could you try clearing the cache & the cookies in your browser, to see if that helps? If you've got any add-ons enabled in the browser, I'd disable those for the time being.

    If that doesn't change anything, I'd want to try testing in a different browser, and seeing if that helps.

    Please advise,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.