SITESPEED Issue! - Google API get blocked from CHINA! ?

Hello There,
I have a Site running where i have big issues out from China to access the page, cause some GOOGLE API get blocked from China, this increases the loading time out from china that the site is more or less not accessible. we have running a CDN and the loading speed from the site is all over the globe (not perfect - But OK)
Link to the site: goo.gl/sK3ANx

attached a screen what files making most issues.

Does anyone of you have any idea how we could solve this issue?
Thank you in advance
Best Regards
Mike

  • Sajid

    Hi freshcom,
    Hope you are doing good today :slight_smile:

    These type of scripts called render blocking scripts that causes delay in site loading.

    This can be fixed by script deferring either by using our Hummingbird plugin. Install this plugin, run a performance test and look for "Remove render blocking resources" in performance report's recommendation (see screenshot).

    Now, read the instructions on next page and configure script deferring. Find the scripts that are blocking the site to load and move them in footer and/or combine together.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:
    Cheers, Sajid

  • freshcom

    Hi Sajid, thank you for quick reply, i have right now WP-Rocket installed on my site which is doing a similar job as your hummingbird, prbly this is the issue why humminbird not seems to work with it. it's doing endless performance testing.. is there any other way to eliminate those 'render blocking sources'.. means they should not get removed as they are needed for site function, but browser should not wait for them if they cant get loaded

    thx & regards
    Mike

  • Sajid

    Hi freshcom,
    Hope you are doing good today :slight_smile:

    There may be some conflict with WP-Rocket for similar components. So its recommended to disable the conflicting components.

    If you are already using the script deferring of WP-Rocket and its still not working then disable WP-Rocket minification module and use Hummingbird Minification for this purpose.

    Or, you can also manually add the defer attribute in html if you know from where that code is coming. See this tutorial for more details:
    http://www.w3schools.com/tags/att_script_defer.asp

    Take care and have a nice day :slight_smile:
    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.