Sitewide Privacy Options Plugin - not appearing

I purchased and installed the sitewide privacy options plugin. I installed via FTP but the plugin does not appear on the Plugins menu and I cannot access any enhanced privacy options in Network settings. The WPMU dashboard says it is installed. Please respond at mmcganney@oakwood.com

  • Elliott Bristow
    • The Bug Hunter

    Hi @Augustus,

    Welcome to the forums!

    When you say you uploaded it via FTP, where did you upload it to? And did you upload it as a zipped up file, or did you extract it first and upload the extracted files?

    If you have the WPMU Dashboard plugin installed, you can install this plugin from that dashboard by selecting the WPMU DEV > Plugins menu and selecting the plugin in there. If this dashboard is showing it as installed, perhaps try deleting it and installing it using this method instead.

    Give it a go and let me know how you get on.

  • Augustus
    • New Recruit

    Hi Elliott,

    Thanks for the response.

    I did manage to get the plugin installed correctly and did a "network activate."

    However, I am not getting the desired result on any of my sub sites.

    I go to Settings --> Reading and select this option: "Anyone that visits must first provide this password: "

    And have added in a password. When I go to the site it correctly asks me for the password to access the site but when I type in the password I am redirected to a page that doesn't exist (http://nationalinstruments.oakwoodworldwide.com/wp-login.php?privacy=4&redirect_to=http://nationalinstruments.oakwoodworldwide.com/)

    rather than let into the site.

    Could this be a conflict with my host, WPEngine? Or have a missed a step in the set up?

    please email me at mmcganney@oakwood.com

    Thank you

  • Augustus
    • New Recruit

    I just received this response from WPEngine regarding the Multisite Privacy plugin:

    "The reason this would work in staging but not live is that it's getting caught up in caching. It's being pretty stubborn with the caching exceptions, as well, so it doesn't look like this is going to work on our platform, I'm afraid."

    So, I need to "return" this plugin and get a refund - how do I do this?

  • Elliott Bristow
    • The Bug Hunter

    I'm sorry that this plugin is having difficulties working with WP-Engine. I know that the WP-Engine caching system does have a tendency to mess up othe plugins.

    Have you tried disabling the caching system in WP-Engine? From my experience with Cahcing systems, they do tend to create more problems than they fix, and half the time it's better to just switch them off.

    If you don't want to disable caching, you would need to speak to the billing team to discuss your refund options via our form at https://premium.wpmudev.org/contact. I can't guarantee that you would receive a refund, since the issue lies with WP-Engine rather than our plugin, however you're welcome to contact them to see what they can offer you.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.