SKU's, Variations, Stock # etc not importing from wp-ecommerce

after running the importer none of my product meta is coming over. Ideas? Only ~800 products. All titles, etc working fine. ideas?

  • rfair404
    • Flash Drive

    This post claims that it imports the following:

    Product Title

    Product Description

    Featured Image


    Sale Price

    Product Category

    Product Tags

    Additional per-item national shipping cost

    Product Excerpt

    Titles came over, and descriptions, and price but not category or tag.

  • Aaron
    • CTO

    I’ve looked over the code and nothing has changed. Categories and tags should be importing just fine.

    I ran a test, and everything imported just fine. I did notice that the product categories will not import unless you have WP ecommerce activated when you import.

  • rfair404
    • Flash Drive

    I tried this again. Here are the specifics of my install, along with a very detailed description of what is happening.

    Server is REHL VPS with whm+cpanel with 8gb RAM.

    WP: 3.3.1 (Multisite Enabled – subdomains)

    MarketPress version 2.5

    WPEcommerce Version

    Products in wpec 505 (458 publiehed, 47 Drafts)

    Product Categories in wpec: 22, most of which are children of one of two parent categories , while the top level cats don’t have products their child categories all contain products. Each product Category has a thumbnail.

    Product Tags: unused

    When I go to the Import section of Market Press is states:

    It appears that you have 858 products from WP e-Commerce. Click below to begin your import!

    I have no idea where this number is coming from as I only have 505 items in wpec.

    I run the importer and let it run its course without closing tabs?

    Allowed memory size of 268435456 bytes exhausted (tried to allocate 82 bytes) in /home/devnixon/public_html/wp-includes/functions.php on line 448

    So, I increased the memory limit to 256 mb (by editing WP_MEMORY_LIMIT in wp-config.php) and ran again. I also asked my host provider to increase the memory to 256 in php.ini.

    Ran the importer again and got the same message. Please help.

  • Aaron
    • CTO

    Seems it can’t handle that much at once. THough I know people who’ve imported thousands without trouble. You could exclude half of the products and import them in 2 batches. To do that you could use phpmyadmin to change the post_type column of half of them first.

    UPDATE wp_posts SET post_type = 'wpsc-product2' WHERE post_type = 'wpsc-product' LIMIT 300;

    then after your first import, remove the imported the imported ones

    UPDATE wp_posts SET post_type = 'wpsc-product1' WHERE post_type = 'wpsc-product';


    UPDATE wp_posts SET post_type = 'wpsc-product' WHERE post_type = 'wpsc-product2';

    and import again.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.