Slide In Error Message wpdb::escape is deprecated since version 3.6!

We continue to receive this error message when using the Slide In plugin. Our designer said that the plugin needed to be updated. Please advise a solution. Thanks.

Slide In Error Message:

Notice: wpdb::escape is deprecated since version 3.6! Use wpdb::prepare() or esc_sql() instead. in /hermes/bosoraweb054/b828/nf.muradauctions/public_html/wordpress/wp-includes/functions.php on line 3078