Slide In plugin messing with RSS feed

Have a problem with my RSS Feed since installing Slide In plugin. As soon as I turn off the plugin it works fine.

feed is:

getting error:
"error on line 16 at column 12: XML declaration allowed only at the start of the document

Below is a rendering of the page up to the first error."
(then the start of the Slide In content - starting with 'close', which i guess is the close button for it).

<div id="wdsi-slide_in" style="display:none;" class="wdsi-slide  wdsi-slide-left wdsi-slide-minimal wdsi-slide-minimal-light wdsi-slide-minimal-red" data-slidein-start="1%"  data-slidein-end="100%" data-slidein-after="0s" data-slidein-timeout="30s" data-slidein-id="1605" >

	<div class="wdsi-slide-wrap" style="width:600px;" >
		<div class="wdsi-slide-control">
	<div class="wdsi-slide-share wdsi-clearfix">
	<div class="wdsi-slide-close"><a href="#">Close</a></div>
</div>		<div class="wdsi-slide-content">
			<h1 class="wdsi-slide-title wdsi-slide-bold wdsi-slide-italic">Secure Your Free Subcription Today</h1>
			<p><img class=" wp-image-1599 alignleft" style="padding-right: 10px; padding-bottom: 10px;" alt="Global CMO May 2013" src="" width="175" height="248" /></p>
<p style="text-align: left;">Global CMO The Magazine brings to you the very latest and best practices in Marketing. Bridging the gap between Marketing theory and Marketing practice, featuring thought-leadership, the latest research, upcoming events and programmes and case studies, each designed to inspire, educate and inform.</p>
<p style="text-align: left;">Make sure you get your Monthly fix of Marketing insights, with the official magazine of Global Marketing Network.</p>
<p style="text-align: center;"><iframe src="" height="138" width="310" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe></p>
</div><?xml version="1.0" encoding="UTF-8"?>
<rss version="2.0"

All that stuff above the XML version shouldn't be showing up on the feed I think.

RSS actually works fine in Firefox on Mac (the Slide In code doesn't show up the top in the Source code), but it errors out in Safari, Chrome and IE,

  • Jack Kitterhing
    • Code Norris

    Hi there @veseycreative

    I hope you are well today.

    Thank you for bringing this issue up, I'm going to see what the lead developer Ve, (@Vladislav) says about this, while this may take longer than your average ticket, I'll try and get you a solid answer ASAP.

    Thank you for being a WPMU DEV member!

    Kind Regards

  • Vladislav
    • Dead Eye Dev


    I sincerely apologise, but I may have spoken too soon about having a Beta with a bugfix ready today. The issue I had in mind seemed to be already taken care of by a different piece of code in the current plugin release. Having said that, let us troubleshoot the issue you're experiencing and fix it as soon as possible. Can you please have a look in your plugin Global Settings, all the way down the page in the "Advanced" section there should be a field named "Custom injection hook". Can you please have a look what is the value of that field? If it says "loop_end" (which is the default value), can you please replace it with "wp_footer" (without quotes, of course - also, casing matters), save your settings and see if it helps? If you wish to revert this field to the default value, you can just remove everything from the field and re-save the settings at any time.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.