Slide In Template Edit not taking effect

Hi there.

I just purchased your Slide-In plugin and am using it on my site here: http://www.caskeyandcaskey.com/. I was trying to alter the html tag for the form title and change it from an h1 to a p or span tag. I did this through going into /lib/box_output.php and it has not taken effect. The title still loads as an h1. I looked around through the other php scripts and didn't see anywhere else this h1 could be being generated. Can you please help?

Thank you.

  • Milan

    Hello @Justin,

    I hope you are having a good day and thanks for asking us.

    Dear member on my sandbox site if I make changes like you made, I am able to see title element changed. For your confirmation I've attached screenshot, please do review it. Change in /wp-content/plugins/slide-in/lib/forms/box_output.php file should be reflected on front end as plugin uses that file to render side in messaged. However one thing should always kept in mind that change to core files won't be preserved when plugin gets updated.

    Furthermore now a days there are lot of css tricks available which lets you make you title element just like simple paragraph or span. So its good solution if you can make change to element via css instead of core editing. In case if you think to go with css way here is selector which lets you target slide in message's title element.

    .wdsi-slide-title{
    color: blue !important;
    }

    In addition to above title stuff there is also one filter which you can use to inject some markup inside h1 element. Below code snippet will let you understand this.

    add_filter( 'wdsi_title', 'wdsi_title_tweak' );
    function wdsi_title_tweak( $title ){
    	return '<p class=&quot;p-title&quot;>' . $title . '</p>';
    }

    If you are sure you've edited that file and want core editing, then Would you be able to send in your FTP and wp-admin credentials so I could take a look?

    You can send the info through our private contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me

    Send in:

    Subject: "Attn: Milan Savaliya"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Once we have this information then I can debug the issue further

    Look forward to hearing back!

    Warmest Regards,
    Milan.