Slide In version 1.2 broken across all my sites

Hi Folks

I have three sites that have Slide In activated, version 1.2 has broken all three sites since I updated.

As these are production sites with varying traffic I have had to disable the plug-in on all three.

The sites were working fine with version 1.1.4.

Each site uses a different theme, and the vendor is either StudioPress or WooThemes.

Please can you advise how I can help resolve this.

The error message shown on the website is: Fatal error: Using $this when not in object context in /home/xxxxxxxxxxxx/public_html/wp-content/plugins/slide-in/lib/class_wdsi_slide_in.php on line 794

From the server log:

[22-Mar-2015 16:17:02 UTC] PHP Fatal error: Using $this when not in object context in /home/xxxxxxx/public_html/wp-content/plugins/slide-in/lib/class_wdsi_slide_in.php on line 794
[22-Mar-2015 16:17:05 UTC] PHP Fatal error: Using $this when not in object context in /home/xxxxxxx/public_html/wp-content/plugins/slide-in/lib/class_wdsi_slide_in.php on line 794
[22-Mar-2015 16:17:08 UTC] PHP Fatal error: Using $this when not in object context in /home/xxxxxxx/public_html/wp-content/plugins/slide-in/lib/class_wdsi_slide_in.php on line 794
[22-Mar-2015 16:17:22 UTC] PHP Fatal error: Using $this when not in object context in /home/xxxxxxx/public_html/wp-content/plugins/slide-in/lib/class_wdsi_slide_in.php on line 794
[22-Mar-2015 16:17:25 UTC] PHP Fatal error: Using $this when not in object context in /home/xxxxxxx/public_html/wp-content/plugins/slide-in/lib/class_wdsi_slide_in.php on line 794
[22-Mar-2015 16:17:54 UTC] PHP Fatal error: Using $this when not in object context in /home/xxxxxxx/public_html/wp-content/plugins/slide-in/lib/class_wdsi_slide_in.php on line 794

Many thanks

  • Adam Czajczyk

    Hello there,

    I hope you're well today and thank you for your question!

    This is quite an uncommon error and I was unable to reproduce it on my test install. However, it seems like changing "injection hook" may be an answer here. In your dashboard please go to:

    "Slide In" -> "Global Settings" page and scroll down a bit.

    Then change a "loop_end" hook to "wp_footer", as seen on the attached image.

    Let me know if it worked! Also in case it doesn't, could you please let me look a little bit closer? For this I'd need some sensitive information about your site, so please contact me using our contact form at

    https://premium.wpmudev.org/contact/

    As a subject line please insert this: "ATTN: Adam Czajczyk" and in the message include:
    - a link back to this thread
    - admin/super admin login credentials to your website
    - FTP data (login, password, host)
    - any other information that you consider important

    Please be sure to select "I have a different question" from the form's dropdown menu.

    Cheers,
    Adam

  • Adam Czajczyk

    Hey Steve,

    I hope you're well today!

    I apologize for the delay here! I was in fact partially off for some time due to some personal reasons, thus resulting in keeping your waiting. I've received your email, however at the moment those access (login) details you've sent me don't work for me. I pretty much suppose that they expired. That said, did you manage to resolve the issue or do you still require assistance?

    Let me know please!

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.