Slide in won't display on home page

For some reason the slide-in plugin won't run the slide on the home page ( it does, however, work here

I even tried assigning the slide directly to the home page but it still does not render. What should we look into first?

  • Tyler Postle

    Hey Andrefredette,

    Hope you're doing well today! Welcome to the WPMU DEV Community :slight_smile:

    What should we look into first?

    There are a couple things we need to do first here. This issue is almost always caused by a plugin or theme conflict.

    1. Check for theme conflicts. Temporarily swap out to the default 2014 theme, or 2015 now if you have WordPress 4.1 :p (just released today)

    Does it work on the home page in the default theme? If so, then it's a theme conflict and we know where to look further for a solution.

    2. Check for plugin conflicts. Deactivate all other plugins except slide in and then see if it works on the home page.

    Does it? If so, then we know it's a plugin conflict and you can re-activate your plugins 1-by-1 until it stops working on the home page again then we know which plugin it is and can investigate further for a solution.

    Common plugin culprits in these situations are caching plugins or security plugins.

    Hope this helps and look forward to hearing back Andre!

    All the best,

  • andrefredette

    We are running the site on WPEngine which has a number of caching implementations. Since it works on the page it seems unlikely to me it's caching.

    Are there any debug tools or logging built into the plugin that would allow us to track the processing of the conditions used to determine whether or not to display the slide?

  • Tyler Postle

    Hey Andre,

    Hope you're doing well today!

    You're right, if it's working on that page then it's likely not caching.

    Did you check for theme/plugin conflicts?

    There is no debug module implemented in slide in but if you turn on wp_debug inside your wp-config.php file then that should give us some more hints to what the issue is too :slight_smile:

    Make sure this line is set to 'true' or if it doesn't exist at all then paste it in.

    define('WP_DEBUG_LOG', true);

    You can also place this line in so the errors don't show up on your actual site:

    define('WP_DEBUG_DISPLAY', false);

    It will create a debug log file in your wp-content folder.

    Let us know what it says :slight_smile: look forward to hearing back!


  • andrefredette

    The Error log had no errors or notices related to the plugin. Are you aware of anyone successfully using this plugin with WPEngine as the host? It looks like you rely heavily on the PHP cookie values and WPEngine advises that php sessions and cookies may not behave normally

    Are there any workarounds or do we need to abandon your plugin?

  • Tyler Postle

    Hey Andre,

    Hope you're doing well today!

    Thanks for your reply. I just tested this on my WPEngine hosted site and it worked on the home page without any issues, I'm using just the default 2014 theme.

    Would you mind sending in your FTP and WP login credentials then I can take a closer look and compare our 2 setups :slight_smile:

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    Look forward to hearing back!

    All the best,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.