Slider Caching issue

When I try to deactivate Hummingbird the Slider doesn't work.

  • Adam Czajczyk
    • Support Gorilla

    Hello Jim

    I hope you're well today!

    I checked your site and at the moment the SG Optimizer is enabled with Hummingbird disabled and everything seems to be working fine there. When I disabled SG Optimizer temporarily, it didn't break the site for me too - I checked it with Chrome and Firefox browsers in both regular and incognito mode.

    However, it's worth noting that with such kind of "intensive" caching, unexpected issues might be happening. The behavior described during the chat states that what was happening was that some assets that were already served through cache, got cached again by another level of cache and additionally CloudFlare also cached references to these cached resources instead of "live" ones.

    So it's something you could call a "cache inception" :slight_smile: In general, whenever you try to either switch caching solution or e.g. disable working caching plugins, it should be done this way:

    - first disable all the caches/caching options in that plugin you're going to deactivate
    - second go to the cPanel and in SGCacher option flush both Static and Dynamic cache
    - then also make sure that CloudFlare cache is flushed

    The order of doing that is important too. In some cases, even after doing that some assets might still be cached by browser so it's best to use "incognito" mode of the browser for checking the site.

    That said, is the site now working fine for you or are you still experiencing the "broken layout"? If it's broken, could you try clearing your browser cache entirely and/or try visiting the site with a browser/from a computer that wasn't ever used to visit the site before? The later is just to confirm whether it's a local computer/browser caching that's interfering.

    Best regards,
    Adam

  • Jim
    • New Recruit

    Hi Adam,

    Thanks so much for the excellent explanation - I have copied it down for future reference.

    The site is no longer broken but the front page slider still sometimes shows and sometimes does not after refreshing the browser - it is very odd. It will show up and then disappear on refresh and then sometimes show up again on another refresh. I will have to dig in further.

    I may just work with my hosting provider and dial back on some of the caching options and simplify.

    Thanks for all the help.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.