Slideshow on Product theme does not always load the first slide...

Has anyone else encountered a glitch in the product theme that results in no slide being loaded on pageload?

I've found that often the page loads but the slider is collapsed (not showing the first slide) and I have to click the slider-nav to load the first slide.

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    @danieldalonzo, I went to the link and while it works for me in firefox, I am noticing and issue with chrome. It appears that the first slide doesn't display automatically in this browser. Tammie's out for a few days, but I'll tag her so she can take a look when she gets back. What browser were you using when you saw this error?

    @psychicventures are you still having this issue? What browser are you using?

  • danieldalonzo
    • Site Builder, Child of Zeus

    thank you for your assistance. i am using safari 5.0.1

    i just went to check again...and when i load the page ( enjoy7.moxietoday.com ), the slider is collapsed - making it so you cant see the first image, once the second picture comes the slider opens up so you can see all the images as the carousel rotates.

  • danieldalonzo
    • Site Builder, Child of Zeus

    ok, so i was having the problem with the slider being collapsed when i first load the page. i had the ''slide contents'' on 'text'. then when i changed the contents to be 'video' or 'video and text' there was no problem, the slider opened great when i loaded the page. however, when i select text and image the slider opens up only as big as the text i have, leaving the rest of the image hidden. and when i select ''image'' for the slider one contents the entire slider is collapsed until the second picture comes.

    i also modified the header.php to autoStart from directions in a previous post in the forum. but i was having the problem before that as well. when i would load the page the slider would remain collapsed until i click next or one of the image titles.

    thanks again

  • Tammie
    • WordPress Wizard

    @all: Are you all using the latest version of the theme and have no javascript errors - sometimes the javascript errors cause issues. If you add a video you also may need to add transparency value to the embed. However, if you can provide links of issues with also what browsers I can check. You need to have a value added to the slideshow though for the slide one height - without that issues can occur. I also need to see it without modified files as of course some of your modifications could have caused issues.

  • rossagrant
    • The Incredible Code Injector

    Me and Tammie have been working on this just now and thought we had fixed it.

    Unfortunately I have noticed it ONLY happens if you have more than one slide in the show.
    If you only have it set to one slide then the height is fine in ALL browsers.

    If you have 2 or more slides in the show then the first one does indeed load in a collapsed state until you cycle through the others or refresh the page.

    I love this theme, but we just need to iron out this somehow.

  • Tammie
    • WordPress Wizard

    @rossagrant: I'm not sure his case is the same as yours at all as this is only replicable so far on your site so lets not assume we've got a global bug quite yet :slight_smile: If this is an issue it seems the latest chrome and safari may have brought it in after the theme release too - I will note chrome is still not bug free by any means but we do support it so lets get a fix.

    All that said could you try the file attached danieldalonzo for me see if that works - you will have to update your header file with your changes again I'm afraid but just incase. I will note this is a long shot as I can't replicate this outside one site so far but lets see. All that aside if you do not have a value set that is large enough under slide one height then everything we're doing will not work anyway - lets make sure we have something like 500 in there to start off so we're nice and safe (just don't put 500px just 500 will work).

  • drmike
    • DEV MAN’s Mascot

    http://www.enjoy7.moxietoday.com/

    Just as a quick aside, that's an incorrect url. The enjoy7 takes the place of the www bit as both are subdomains. Most search engine bots and something like 20-30% of the net can;t view or follow such a link.

    Normally I give example links from google showing that they ignore the url with both subdomains but this site hasn;t been indexed yet.

    Just a FYI. You shoot yourself in the foot when you do such a link in terms of SEO since Google and the rest don;t see such a link.

  • danieldalonzo
    • Site Builder, Child of Zeus

    @dr mike - first of all, thank you for your support across the wpmudev site. im not sure what u mean by incorrect url - when i click the link it takes me to the site - does it not work for other people? do u mean if i was to advertise the site i shouldnt put the www infront? or when i give the link in support forums i shouldnt use it? am i shooting myself in the foot when i put a link in this support forum for the site with the www infront of it? or if i were to put the link elsewhere?

    @tammie and everyone else - i didnt edit any code in the theme or replace the header file with your attached document, i activated the theme for my main site - http://www.moxietoday.com and I do not have the issue of the collapsing slider. it works fine. maybe it was something in the subdomain enjoy7.moxietoday.com?

  • Tammie
    • WordPress Wizard

    @danieldalonzo: Can you state your settings / screenshot them - needs to see if you've got a height set.. what you've also got set for the other settings. You are saying the header doesn't work (file I attached) and if so you obviously have something else going on. Make sure you have all other plugins / code turned off before you test also please.

  • danieldalonzo
    • Site Builder, Child of Zeus

    @tammie - long story short, i accidentally deleted my wp-content folder while doing some modifications in my ftp client. needless to say my entire network of sites is down and the nearest backup i have is from august 20th - my fault for not backing up more frequently...i usually do but the summer got the best of me. my hosting company assured me they are working on it and all my sites will be restored just how they were before the crash. once the sites are back up i can provide you with the above information you asked.

    thanks for all your help.

    in the meantime, do you have any suggestions for an easy back up and restore process for my wordpress multisite network?

  • danieldalonzo
    • Site Builder, Child of Zeus

    @mason - thank you. my hosting company has been jerking me around the last 72 hours. they instructed me to do move folders into another subdirectory and it messed up the database connections..i think that's what they are saying. but the thing is, for the last 3 days I would call support and they would tell me the site is being worked on and it will be done in a few hours. so i have been sitting by the computer waiting for it to be fixed but its never working. then i call back again 48 hours later and they tell me nobody has looked at your problem yet.

    my question is, do you or anyone know a good hosting company that offers wordpress support? i saw the wordpress VIP hosting and support but it is way out of my league at the moment.

    thanks again,

    dan

  • Mason
    • DEV MAN’s Sidekick

    Hiya Dan,

    Gads. That's terrible support. Again, sorry for your troubles. For our WP.MU service we use and recommend pSek Hosting. As you can imagine, they power heaps of WordPress sites!

    I've personally used HostGator and always found their support available and knowledgeable. I'm sure others here would have recommendations as well, but that's my 2 cents. Good luck to ya!

  • drmike
    • DEV MAN’s Mascot

    I;m going to reopen it just for a second to point out that wp VIP hosting is basically by invite and review only. It's not something you sign up for although you can ask to be a part of it. They're looking mostly for high volume sites of like 5 million page views a month and/or high profile sites.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.