Slow admin

I reported getting 405 Not Allowed nginx/1.12.2 Errors and took it up with the hosting they provided me access to the errors logs that do not show anything

I had issues with all posts and pages now it is just on the front page I have been stripping things out to see if I can trace the issues today the 405 error happened again and the front page in admin when you save takes ages or times out

Regards John

  • Patrick Freitas
    • Staff

    Hi John

    Sorry to hear that you are having this problem.

    Nginx should be a very fast service, in most of case this is a hosting problem, however, we want to make sure is not any plugin / theme conflict.

    So, would you mind please run a conflict test?

    Remember, is important that you run this test in a staging site, if you can’t do it you must create a full backup.

    Please deactivate all plugins and check if the problem is gone. If so, then enable all plugins one by one and find which one is creating the issue.

    If you still having this issue, could you do a theme test, much the same as the plugin test, but now you’re testing themes!
    Activate one of the default WordPress themes, like Twenty Sixteen or Twenty Seventeen.
    Here you will find more information: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    Let us know the results that you get,
    Best Regards,
    Patrick Freitas

  • John
    • Site Builder, Child of Zeus

    Hi Patrick

    I did plugin by plugin by disconnection via my hub

    it appears to be the plugin smart crawl pro once that was disconnected the save went back to normal for the home page

    I have left if disconnected Please let me what to do next

    Thanks John

  • John
    • Site Builder, Child of Zeus

    Just a thought we lost all the settings and meta links last time so whilst I have left the crawl on disconnect I do not want to have to re key all of the information if I can help it.

    Also without the plugin connected we are not getting the page links so i hope you can help me as soon as you can

    Regards John

  • Patrick Freitas
    • Staff

    Hi John

    Sorry to hear that Smart Crawl Pro, did you run the plugin test on a Stating site or did you create a full backup of your data as I mentioned above.

    However you can reactive the plugins Smart Crawl Pro plugin and we will run some test to check if we can fix the issue. However If you only had deactivated the plugin when you activate it the data and configuration should be kept. After fix the problem we can restore the backup and apply the same fix.

    Let me know when you activate the plugin and we can run some more test and see if if fixes the problem.

    Have a Great Day
    Best Regards,
    Patrick Freitas

  • John
    • Site Builder, Child of Zeus

    Hi Patrick thanks for the reply

    I only did the plugin test taking away a plugin at a time until the front page could be saved when I then put all back except the crawl pro

    I tested a save first thing and all worked I will now via the hub activate the plugin and report if we are back to slw saves

    Regards John

  • John
    • Site Builder, Child of Zeus

    I have activated the plugin and the admin of the front page has taken virtually 2 mins to save on the front page
    I have not done anything else as all a bit to technical for me please if you can let me know what to do

    I am on a bit of a deadline as we have new clients wanting to start with us asap we have on desktop page speed reached 84 score yesterday mobile 69 so things are working

    it is just that I lost two days due to losing all the meta data last time

    Thanks again Regards John

  • Patrick Freitas
    • Staff

    Hi John

    Sorry to late reply, I was running some test on my website trying to get the same result and making some research about this issue.
    I was copying the PHP configuration when I could see that max_execution_time is set to 0 and the PHP memory can be improved.

    Wouldn't you mind please to send me the FTP information and I will have a closer look.

    Note: Don't leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:
    Subject: "Attn: Patrick Freitas"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Let me know when you send the information and I can have a closer look
    Have a great day,
    Patrick Freitas

  • Patrick Freitas
    • Staff

    Hi John

    Thank you for share the informations, there is a really strange behavior on this WordPress, I can see that the max_execution_time is set to 300 on php.ini and I tried to increase the PHP memory but got the same slow dashboard, I enabled the WordPress debug mode and could see a issue on the debug.log.

    [13-Jun-2018 18:00:36 UTC] PHP Notice: Undefined index: allowfeed in /home2/waalli0aagp6/public_html/wp-content/plugins/wpmu-dev-seo/includes/tools/autolinks.php on line 97

    I'll be forwarding this to our SLS and they will be having having a closer look o this.

    Have a Great Day,
    Best Regards,
    Patrick Freitas

  • Panos
    • SLS

    Hi there John ,

    This sounds to be related to the Automatic Sitemap Updates feature. I believe that when trying to update the sitemap during the post save, the data is more than what the server can handle.

    I don't see any option to edit from front end on your site. Could you try deactivating this feature and then save a post again? You can disable that feature from:
    WP Admin -> SmartCrawl -> Sitemap -> Advanced tab and at the bottom you should see the Automatic Sitemap Updates option.

    If this is the case indeed, temporarily you can update the sitemap manually from
    WP Admin -> Dashboard where you will see the followinf dashboard widget:
    [image pos="0"]

    Please let us know if you would like us to test this on your site and how to edit from the front end.

    Kind regards!

  • John
    • Site Builder, Child of Zeus

    I did that as suggested and un ticked the box went to the front page and it failed to update I cleared the cache tried again and again all we got was 405 error again

    When you look at the edit you have done, it actually is updating I also noticed in the sitemap bit

    Your SEO crawl has timed out due to an unknown error. Please try again or contact support.

    What do we need to have in the site map everything or should we limit it we had a plugin before simple sitemap has that anything to do with it?

  • Patrick Freitas
    • Staff

    Hi John

    Sorry to delay here, we still investigating the issue, but it is related to the Nginx, would you mind please contact the hosting provider, they can have a fresh look on the problem.

    About the meta data, I made a test on my end, I created some post and set the metadata, I deactivated the plugin and edited the post.
    After activate the plugin again the previous metadata kept there, once you don't remove the plugin or remove the page it will keep the metadata. Just always is better to create a backup to save all the site information before do any test, if you are not sure how to create a full backup wouldn't you mind please ask the host provider, they can create it for you.

    After create a full backup you can deactivate the plugin edit the a page and activate to be sure the all metadata still there.

    Best Regards,
    Patrick Freitas

  • John
    • Site Builder, Child of Zeus

    Patrick did you see the reply re sitemap? From Panos?

    I sent this to Hostgator on an outstanding ticket below

    Hello again

    We have continued to get the following error

    405 Not Allowed
    nginx/1.12.2

    We have a plugin that may be part of the problem it is a setting somewhere or a server issue error

    It makes the front age of https://motorhomescampervans.net load slow it goes to the error message but does save the changes

    All the other pages and things save ok

    Could you advise if a server issue thanks John

  • Patrick Freitas
    • Staff

    Hi John

    We made almost all possibles test on the plugin, I tried to replicate on my end and I had no problem. but this issue:

    405 Not Allowed
    nginx/1.12.2

    Is a server side warning the host provider can have a closer look, if you would like, ask them to copy the site to a stating website using Apache and check if you have the slow problem

    They have the knowledge to do this test, but always ask them to create a backup first.

    Best Regards,
    Patrick Freitas

  • Patrick Freitas
    • Staff

    Hi John

    I do believe that Nginx is running on a low memory and it is making the site slow, the host provide would be able to increase this memory on Nginx config file. It do happen because the shared host has a default config, and it need to be changed on some specific situation but on most on the cases the default configuration can handle the website without problem, and they can save memory and resources on the server.

    Best Regards,
    Patrick Freitas

  • John
    • Site Builder, Child of Zeus

    Hi Patrick

    Hostgator inform me that they can not up the memory I will have to upgrade so I think I need to look round for a package unless you have any other suggestions I have reduced the sitemap so do you have any other suggestions?

    I cannot prove the sitemap make it to manual from Automatic tried that and it did not work

    Regards John

  • Patrick Freitas
    • Staff

    Hi John

    Sorry to heat about the news from Hostgator, they can inform how much memory the plan is using now? if is something like 128M to 256M the best option would increase it.

    However I can see that the website is loading fine on the front https://gtmetrix.com/reports/motorhomescampervans.net/SOs3qX1c
    But you could ask the hosting provider to increase the plan to a stating plan to see if the problem is gone. As I said, we did all the possible tests on the plugin. I still thinking that you could ask the hosting provider to migrate this to a Apache Plan and check if the problem is gone.

    Best Regards,
    Patrick Freitas

  • John
    • Site Builder, Child of Zeus

    Patrick

    News from Hostgator

    Hi Michael

    Thanks for the reply

    I logged into the admin of the site went to the wordpress dashboard selected edit the front page changed text at the bottom of the page

    Hit save and it hung for over 1 min in time and then went to a blank white screen with the error at the top

    405 Not Allowed
    nginx/1.12.2

    https://motorhomescampervans.net/wp-admin/post.php

    Now when you try again the page takes a while to save and does not give the error. The funny thing is that the text I change has been saved

    Our plugin people believe this is a memory issue

    By all means do the same as I have done so you can see the error or at least see how long it is to edit the front page

    The other posts and pages save fine

    Thanks hope that helps Regards John

    On 2018-06-22 00:38, cases-support@hostgator.com wrote:
    Hello,

    In order for us to safely make adjustments to your website, we need
    you to provide us with step by step actions that you approve of us
    making on your website that allow us to generate the error. This will
    ensure we are seeing the exact same problem you have encountered to
    ensure we are able to fix it.

    I saw some issues while accessing your site that were generating
    errors to the logs. In order to remedy those errors, I have adjusted
    the .htaccess so that you are running PHP 5.6 and updated your php.ini
    to work with PHP 5.6.

    Please let us know if you run into any further errors.

    Michael G.
    Linux Administrator

  • Patrick Freitas
    • Staff

    Hi John

    Wouldn't you mind please check if the problem is gone after they send it?

    I saw some issues while accessing your site that were generating
    errors to the logs. In order to remedy those errors, I have adjusted
    the .htaccess so that you are running PHP 5.6 and updated your php.ini
    to work with PHP 5.6.

    And provide to them a step guide, much same that you did here.

    1- Login to the WordPress dashboard,
    2 - All Pages > Select a Page,
    3 - Edit Front Page,
    4 - On bottom of page, add a text,
    5 - Save it
    ...

    Something like it, reproducing the same situation they can check for the nginx issue.

    Best Regards,
    Patrick Freitas

  • John
    • Site Builder, Child of Zeus

    All

    Update we all have now moved host to Siteground as previously posted and they are looking at the issue I have updated smart crawl and re- tested the slow front page admin still times out and does update changes, not sure where we have got to as been a while since I sent all the logins

    Regards John

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.