Slow loading appointments page

Hi,

My appoint page is loading very slow and I don't know what causes the problem. It is only with this page

Kr Marion Jebbink

  • Marion
    • Design Lord, Child of Thor

    Hi,

    I did not read a message from your college correctly. So i thought you already tried to find out my problem about slow loading from my appointment page.

    I have a second problem. When I start the agenda it shows correctly with days and hours people can make an appointment. But when they change the kind of appointment my agenda is not correct anymore. So people can make appointments at times already booked.
    I hope you understand what i mean. My english is not that good

    Marion

  • Tyler Postle
    • CGO

    Hey Marion,

    Hope you're doing well today. I checked your site and the Appointments page doesn't load any slower than your other pages for me. Your whole site does load a bit slow for me though.

    This guide here can help you speed up your site: https://premium.wpmudev.org/blog/speeding-up-wordpress/

    I have a second problem. When I start the agenda it shows correctly with days and hours people can make an appointment. But when they change the kind of appointment my agenda is not correct anymore. So people can make appointments at times already booked.
    I hope you understand what i mean. My english is not that good

    I see what you mean, the appointments are being imported from gcal right? These appointment times don't apply to the service provider themselves, just the service, which is why the other services are still showing available.

    What you want to do here is link the gcal to your specific service provider, from your edit profile screen. As seen in my screenshot.

    remove the settings from your main Appointments+ gcal and add them to your user gcal instead, this way the imported appointments will be assigned specifically to your provider and it will block out the times across all your services.

    Let me know if you have any further questions on this.

    Cheers,
    Tyler

  • Tyler Postle
    • CGO

    Hey Marion,

    Hope you're doing well today! Sorry for my delay.

    Would you mind granting support access again and sending in your FTP so I can have another look?

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    **If you re-grant support access then no need to send in wp-admin credentials. I'll still need FTP though.

    I'm thinking this is likely a configuration issue. Look forward to hearing back!

    Cheers,
    Tyler

  • Tyler Postle
    • CGO

    Hey Marion,

    I can see in your reserved by gcal appointments list that your last 5 gcal appointments have imported properly to your service provider. These appointments seem to be blocking off appropriately for all different services.

    It's still the previous ones that are only applying to one service. Those ones will need to be re-booked and imported in order to be properly assigned to your service provider.

    Alternatively, you could book filler appointments for those days form your appointments backend or frontend to block those times off. It may be easier to remove the gcal events then re-add them though.

    Let me know if you are still seeing an issue that my above response doesn't address.

    Hope you're having a good weekend!

    Cheers,
    Tyler

  • Tyler Postle
    • CGO

    Hey Marion,

    Glad that is all sorted :slight_smile:

    As for the slow loading. Is it the Appointments+ backend settings page or the frontend booking page?

    Can you re-grant access again? Then I'll have another look. I didn't notice any slow loading last time I was logged in.

    Look forward to hearing back.

    Cheers,
    Tyler

  • Tyler Postle
    • CGO

    Hey Marion,

    Sorry for my delay. I checked out your site again and again the whole site actually seems quite slow, not just the Make an Appointment page.

    I checked the "time to first byte" on your appointment page with this tool: http://www.bytecheck.com/

    The result was 6 seconds. This means that before the page even begins loading any of the files it takes 6 seconds. That usually indicates a server issue as it takes 6 seconds to connect to the server hosting your files then it loads/renders them in the browser.

    I would ask your web host about this to see what ways they suggest to speed up the server.

    One way is to implement caching. This is the most popular way to increase speed.

    We provide some suggestions on this post here that I linked earlier: https://premium.wpmudev.org/blog/5-quick-ways-to-speed-up-your-wordpress-site/

    I would ask your host before implementing any caching plugins because often they may have caching features on the server that they could optimize/turn on for you.

    If you have any further questions just let us know.

    Cheers,
    Tyler

  • Marion
    • Design Lord, Child of Thor

    i dropped the question by the host.

    But after the appointments update another issue comes up. And i really hate toothier you again. But all days in my agenda are booked as full.
    So nobody can make an appointment.
    I think I start to dislike the plugin

    Have a good day

  • Tyler Postle
    • CGO

    Hey @Marion,

    It looks like you managed to get the 1.5.3 update we released the other day, we pulled it shortly after release as it had some issues. If you deactivate and delete that one then re-install Appointments+ through our WPMU DEV Dashboard that will give you 1.5.2 again and will fix the issue you're having.

    We are re-releasing the 1.5.3 update soon :slight_smile:

    @catalyst, I haven't heard of that being an issue yet. Slow loading due to number of services when relating them all through the shared resources add-on. If you deactivate the add-on is it still slowing? Wondering if just that part is what is slowing you down. If you could create a new thread on that we can help further: https://premium.wpmudev.org/forums/#question

    Seems to be 2 separate causes for slow loading here so would be best to have a new topic to avoid any confusion.

    Cheers,
    Tyler

    PS @Marion, you won't lose any of your settings or anything when rolling back to 1.5.2, it's all saved in the database :slight_smile:

  • Marion
    • Design Lord, Child of Thor

    I am really not amused anymore. I reinstalled the earlier version and used the same calendar settings i used before . When I test the connection i get error message. see attachment
    This plugin is take a lot of my time. I choose it because it was easy to use. Well maybe I am not smart enough but I have lots of problems and I can not trust it. When I launch my site it has to be working
    Hope the problems will be over soon.

  • Tyler Postle
    • CGO

    Hey Marion,

    That error was not there before installing the earlier version? Can you go to your gcal settings inside Appointments+ > Settings. Find the key file field and then check your key file location to make sure it is still there. Rolling back the plugin may have removed it, sorry about that.

    The folder you want to check is:

    /wp-content/plugins/appointments/includes/gcal/key

    If you need to re-add it again then go to your google console: https://code.google.com/apis/console/

    Select the project you created for Appointments+ and then navigate to:

    Enable and manage APIs > Credentials > Click your service account. Then click "Generate New .p12 key" and import that to the above key folder again. Then copy just the part before the .p12 and paste that into the gcal settings overwriting the old key.

    Then it should be all good again :slight_smile: if you have any troubles just let me know.

    Cheers,
    Tyler

  • Tyler Postle
    • CGO

    @Marion, it should automatically download when you click "generate new .p12 key". Can you try in a different browser? Or it may have downloaded in the background so you could try searching for that file in your downloads folder.

    Once you have it just upload to your /gcal/key directory as mentioned above and paste in the new file name to the settings.

    Cheers,
    Tyler

  • Marion
    • Design Lord, Child of Thor

    Today i delete all everything I did and create a whole new agenda. I reinstalled appointment+. The p12 file is copied to the place it belongs and I am very sure all settings are correct! I still get the error that the key file does not exist. It does exist! Again when I go to my website and click on next month the page is opening very very slow. Will you please help me to realise this service to work. At some stage something goes wrong. I will regrant permission for you

    Grtz Marion

  • Tyler Postle
    • CGO

    Hey Marion,

    Thanks for sending that in!

    I noticed that your .p12 key in your /appointments/includes/gcal/key/ folder didn't match the .p12 key you had in your Appointments+ settings. So I overwrote the one in your settings with the one you have uploaded; however, there is still a permissions error.

    What I'm thinking here is that the .p12 key you have uploaded isn't the same as the one associated with your project in the google console. Can you have a look at the .p12 key in your project inside the google console and make sure the file name matches? If not, then create a new one and download it then use that instead.

    This is the file name for your current one: Onlineagenda-efa138ef04b2

    Look forward to hearing back!

    Cheers,
    Tyler

  • Marion
    • Design Lord, Child of Thor

    i find it pretty weird. The attachment is the p12 I use. i already created a new one because the first one did not function
    I dont understand why names did not match because i copy-paste the file name and tried it several times.

    Grtz

    Marion

  • Tyler Postle
    • CGO

    It all looks to be fine now with the .p12 key. Not sure why you are still getting that error. Do you use your personal gmail for the integration? Just wondering because if it's just a secondary account you use then perhaps I could get access to it to see your google project settings.

    If it's your main account then I totally understand you wouldn't want to give access to that away.

    In that case, would you mind if I tried connecting it to a test gmail of my own? Just so I can confirm whether it is a configuration issue or a communication issue? Should help us narrow it down.

    Talk to you soon! Cheers

  • Marion
    • Design Lord, Child of Thor

    It's my main account. Tell me were I can sent my password

    I trust you.

    It is also strange the p12 key was not the same in the settings. Because I copy paste the thing.

    I am not totally unexperiend with computers. But this is strange. Especially because it worked before I update to plus version

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.