Slow loading of all spirit sites

Hi there friends of Wpmudev. First of all, Spirit and Upfront are great to work with/on.. best tools you can have (thumbs up). But.. why does every page i make in this "style" - load slow, compared to many other WP sites? It looks like the Upfront i slowing things down a lot. Does someone have a great idea how to "speed things up"? (Of course i have also try to use it without any plugins). I need a good idea to make my Upfront sites faster in frontend. Please respond, i am pulling out all of my hair

    Adam Czajczyk

    Hey post41,

    I hope you're well today and thank you for your question!

    I've checked your site and tested it with Google Page Insights and some other tools. Although it seem like it's loading a bit slowly indeed, there's surprisingly no important/unusual issues reported. One thing that bothers me is a "server response time" which seems to be too long.

    You're using our Spirit theme and this should work fine as it does on other pages of our members. What I'd suggest would be to:

    1. Take care of images, preferably optimize them with our WP Smush Pro plugin
    https://premium.wpmudev.org/project/wp-smush-pro/

    2. Implement caching. Many members of our community use W3 Total Cache or WP Supercache for this. I'm a big fan of in-built Wordfence cache though as it is not only fast but also improves security a lot:
    https://wordpress.org/plugins/wordfence/

    3. Last but not least: in case of W3TC or WP Sc you won't need it, but with Wordfence it's a good choice: WP Super Minify
    https://wordpress.org/plugins/wp-super-minify/

    If all this steps still doesn't improve page speed significantly, I'd go for CDN such as CloudFlare.
    Also, please note that if using any of aforementioned plugins, you may have to disable them (and empty all caches) before editing your site with Upfront editor.

    I hope that helps!
    Cheers,
    Adam

    Adam Czajczyk

    Hey post41,

    I've tested the very same theme that you're using with Google Page Insights and my testing WP install and it seems to be running faster than your page. That leads me to a point that either there might be some kind of issue with your server's performance or perhaps it's not working fine with one of plugins.

    As for server's performance. This is not very likely but I've encountered some cases where a kind of firewall was blocking parts of Upfront from being loaded properly/fast.

    That said, please give CDN a try and let me know if it helped!

    Cheers,
    Adam