Slow page load speeds, created with Upfront

Hello,

I've created a demo site (http://coastaldataenterprises.com/members/), and have been using it as a testbed to throw all of the new plugins and themes from WPMU Dev at, but the load times of the resultant pages is pretty bad, I'm wondering what I can do to help this.

I'm using Hummingbird too, but I've found I have to be very conservative with its settings while working on the site, or else it causes problems, maybe mainly because I was editing the header a lot, as per the warning? I'm leaving the header alone now, though, and am re-enabling the minification to see how much that helps.

I would definitely be open to suggestions though, on design concepts or such that affect page load performance.

Thanks!

--Jon

  • Rupok

    Hi Jon,

    So sorry for the inconvenience you are having.

    Thanks for providing the URL. I checked your site and it seems like your initial server response is more than 6 seconds which is very unusual and that's causing this huge load time. If initial server response was under 1 second (which is very usual), then your site would load in 4-5 seconds and that's not a very bad score. Please check the attached screenshot for reference.

    Now, we can help you optimize your site but all optimization will come to work after your server starts sending responses. You can minify your scripts, optimize images and other assets, but if you server takes longer to send those, then overall load time will be higher.

    Can you please change this site to another host and check if initial server response time is same? If not, then this is definitely your server issue. In that case, can you please talk to your host regarding this?

    Please let us know what they say about this. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.