Slowness of upfront!

Both as a registered user and a backend developer on my website, the speed of processing is so unbearingly slow! Each page takes 15-20secs to upload, each change takes 45secs to be implemented.

  • Nithin
    • Support Wizard

    Hi Amit,

    Hope you are doing good today. :slight_smile:

    Sorry to know that you are having issues with Upfront, I checked your website, the Upfront did take 40 secs to load initially, other than I was able to notice that the page loads were less than 10 secs in the Upfront editor. To improve performance, I have optimized the settings under Upfront > Experimental , and this should help in loading the editor a bit better.

    I was able to notice that you are using an older version of Upfront v1.3.3, could you please update the theme to the latest version v1.4.2, and check whether it improves the Upfront editor speed, as the latest version is more optimized when compared to the previous versions. You can update the Upfront theme under WPMU DEV > Themes

    Also, would recommend you to disable all the plugins, and check whether it improves the editor speed, if yes, would recommend you to please run a quick plugin conflict test as illustrated in getting support manual (flowchart), and rule out whether any plugin is causing this issue.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please let us know how that goes, so that we could give a closer look. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Amit
    • Flash Drive

    Dear Nithin,

    Thanks for your email and help.

    We updated the theme and deleted the plugins that were redundant. We are not keen to disable the plugins and run the conflict test you advise for fear of compromising the functionality/lay out of our site.

    The site is still slow. We would appreciate further help.

    Many thanks.

    Best regards,

    Amit

  • Rupok
    • Support Ninja

    Hi Amit,

    I found that Support Access is expired. I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I need to see each query to find out if any specific asset is causing this delay or there are many.

    We are not keen to disable the plugins and run the conflict test you advise for fear of compromising the functionality/lay out of our site.

    Plugin conflict test is really important because we can't make sure that any of your current plugin is not causing this issue. As you are not keen to do this in your live server, can you please create a clone of your whole site to any staging server and do the plugin conflict test there? As you will be testing with a cone site, your live site will be safe and we can know from the staging server if any plugin is conflicting or not.

    To know more about how you can create a staging server, you can check these guides:
    https://premium.wpmudev.org/blog/testing-environment-wordpress/
    https://premium.wpmudev.org/blog/set-up-staging-site-cloner/
    https://premium.wpmudev.org/blog/wordpress-staging-environment/

    Please let us if this is possible, and if possible, what is the result. I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Kasia Swiderska
    • Support nomad

    Hello Amit,

    I run test in google page speed and it looks like your server response time is very high - over 5 seconds.
    Before I will run plugin conflict test I would like to rule out that Upfront theme is culprit and switch for moment to default WordPress theme and then see if server response time will be the same or lower.
    This test will take me less than 5 minutes. Is it ok with you?

    kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello Amit,

    So I've run tests and server respons on default theme was better, still high (over 1 second) - but better than responses with Upfront (2,2 and 3,2 seconds).
    Even without plugins it was not loading as fast as we could expect.

    However on one test I saw that there is long response from google Authorize - your site does not have API Key for Google Maps inserted in Upfront -> General -> API KEYS. Could you provide that key? This is long shot, but i would like to be sure we are not missing anything.

    Also, I noticed that you have WooCommerce installed. If you are planning to use Woo now I have to advise to not use it with Upfront themes as its not compatible with that plugin yet. I know that is next goal for Upfront, but at the moment they wont work well now.

    kind regards,
    Kasia

  • Amit
    • Flash Drive

    Hi Kasia, thanks so much for your help with this. We've removed WooCommerce as per your advice and this has improved things a little but it still runs slow. We read your advice re Google Maps which we don't really use on our site. Either way, how would we go about providing you with key? Thanks so much, appreciate your ongoing efforts, Amit

  • Nithin
    • Support Wizard

    Hi Amit,

    Hope you are doing good today. :slight_smile:

    We read your advice re Google Maps which we don't really use on our site. Either way, how would we go about providing you with key?

    I looks like the support access is disabled. You can share the key in the quick message section of the dashboard plugin, under WPMU DEV > Support.

    You can also save the key under, Upfront > General, and check how that goes, when it comes to your response.

    If you doesn't see any improvement, please enable support access, in order to check your website settings.

    Kind Regards,
    Nithin

  • Amit
    • Flash Drive

    Hi Nithin - unfortunately the site is still slow even after adding the google API key as advised. Are you able to check it out to see if there is anything else we can do to increase the speed?

    Also we are looking for a pagination plug in that works with upfront so that we can list all our page titles in alphabetical order on the master pages. Are you able to advise the best one to use for this?

    thanks
    Bijal

  • Kasia Swiderska
    • Support nomad

    Hello Bijal,

    I realized that you mention that Upfront editor is problematic when updating site and take lot of time to load - but I checked it and it works fine - not even close to 45 seconds - on my side its around 3 sec to save changes. Can you tell me if this is working better on your side too?

    I tried one more thing - but it didn't help with overall speed of site. I'm not sure if this will be possible to cut more of time load without cache plugin.
    If your server response is already long (over 1 second) - and Upfront is not the lightest theme than it will be hard to get lower than 2,6 seconds that is now on test whiteout caching.
    You can use WP Super Cache plugin with help of our Hummingbird plugin https://premium.wpmudev.org/project/wp-hummingbird/ and WP Smush Pro https://premium.wpmudev.org/project/wp-smush-pro/
    Hummingbird will enable gzip compression and browser cache - Smush will help with images optimization.
    But real caching will be done by cache plugin like Super Cache (or W3 Total Cache).

    Also we are looking for a pagination plug in that works with upfront so that we can list all our page titles in alphabetical order on the master pages. Are you able to advise the best one to use for this?

    I found those plugins that will allow you to place a list of all pages on page
    https://wordpress.org/plugins/page-list/
    https://wordpress.org/plugins/list-pages-shortcode/

    but this will not work with pagination. There can be only one list of pages.

    kind regards,
    Kasia

  • Amit
    • Flash Drive

    Dear Kasia, thanks for your ongoing support.

    Could you help me with the Mini Loops plugin please? I think this is what we're looking for in order to sort posts in alphabetical order in a category. I need to add the following short code:

    [miniloop categories="28" order_by=title order=ASC number_posts=100]

    to the Mini Loops plugin which I've installed and activated.

    Could you tell me how including where I insert this code when I go to Plugins-->Editor?

    Thanks,

    Amit

  • Nithin
    • Support Wizard

    Hi Amit,

    Hope you are doing good today. :slight_smile:

    Could you tell me how including where I insert this code when I go to Plugins-->Editor?

    I'm not sure whether I'm following you here, you don't have to add the above shortcode, in your miniloops plugin files. You'll have to add it in your themes default visual editor of your page. Since you are using Upfront, you could either add it in your post content, or make use of the Widget element, and then select Text Widget, and add the following shortcode in it.

    I don't see anything in the plugin doc, that mentions about adding that shortcode in the plugin files, or is it in your custom plugin? Please advise if I'm missing out anything here. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Amit,

    Hope you are doing good today. :slight_smile:

    Thank you for sending the link, the tutorial only mentions to make use of the plugin shortcode. To make it work, as mentioned in my previous reply, you'll have to add the following shortcode, in your default WordPress visual editor of your page, or in your Upfronts Widget element as shown in the above screenshot:
    [miniloop categories="29" order_by=title order=ASC number_posts=100]

    Please give a try, as mentioned in my previous reply, and let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Amit
    • Flash Drive

    Hi Nithin, thanks for your msg. So, I dragged a Widget onto the page that I was trying to alphabetise (Business, Entrepreneurship, Start-Ups) and inserted in the short code as per your instructions at the top in Upfront, replacing the 29 for 28 (since that is the Category id of the Category I am trying to alphabetise) but it doesn't seem to work. Could you help me please? Thanks, Amit

  • Nithin
    • Support Wizard

    Hi Amit,

    Hope you are doing good today. :slight_smile:

    I checked your website, and unfortunately it seems like the plugin is not compatible with Upfront editor, and hence doesn't show any results. I was able to make this work only when I added the shortcode through the default WordPress visual editor. You can check the test page, I created here: http://www.shrewdhippo.com/atest/

    I checked for other similar plugin, and it seems like Display Shortcode plugin might fit to your needs, and it seems to work fine in my test server, running an Upfront theme. Could you please check, and see whether it works:
    https://wordpress.org/plugins/display-posts-shortcode/

    You can find all the parameters to make use of the plugin shortcode here:
    https://github.com/billerickson/display-posts-shortcode/blob/master/README.md#parameters

    Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Amit
    • Flash Drive

    Dear Nithin, I've placed [miniloop categories="28" order_by=title order=ASC number_posts=100] into the visual editor of the page I want to alphabetise the categories of but it's not working - the categories are not in alphabetical order. Could you help resolve this please?

  • Amit
    • Flash Drive

    Hi Nithin, we have another issue as well which I wonder if you could resolve. When we're adding an extra category called "The Intelligent Investor" to one page (Business, Entrepreneurship, Start-Ups) it keeps automatically adding it to the bottom of the 'Digests' page as well, which when we delete, also deletes the category from the 'Business, Entrepreneurship, Start-ups' page.
    Thanks, Amit

  • Kasia Swiderska
    • Support nomad

    Hello Amit,

    Please create separate thread about issues with other plugin. As you see subject of thread is "Slowness of Upfront" and now we are solving problem that is not related to that.
    That will be confusing for members looking for solution for similar problem and also for other staff members.
    It's better to keep each not related issue in separate threads.

    kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello Amit,

    I tested your site today (when I was responding to your other thread) and I haven't seen anything you described. It was working fine on my end, it wasn't crashing and editor speed was normal.
    I tested it again just now and I could not still see the issue.

    Is this showing on specific pages you are editing? Maybe you can change browser and see if issue is still there?

    kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello Amit,

    I tested your site today (when I was responding to your other thread) and I haven't seen anything you described. It was working fine on my end, it wasn't crashing and editor speed was normal.
    I tested it again just now and I could not still see the issue.

    Is this showing on specific pages you are editing? Maybe you can change browser and see if issue is still there?

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.