Smart Crawl not caching as expected

Hi there, I'm having trouble with CPU processes when I turn on smart crawl.

Its spiking the CPU right now, but I would imagine that it shouldnt take so much resources once the site is cache. I'm using WP Rocket and Cloudflare for caching.

Each time I turn on smart crawl, it uses up to 3x the CPU power. What am I doing wrong?