Smart Crawl reduces admin posting to a halt

Hello,

Since the new Smart Crawl update, creating and managing posts has slowed to a halt. Often my server times out when I click "All Posts" and cycle through the pages.

However, as soon as I deactivate Smart Crawl the speed returns to normal.

I have just run a test deactivating all plugins and reactivating the Smart Crawl plugin and still, Smart Crawl stifles speed. My client's site has multiple users who create drafts for review then publish and all were complaining last night it was impossible to get work done.

I have opened Support Access please take a look, currently, Smart Crawl and all non-essential plugins are deactivated. Before you ask, yes I did a quick test deactivating WP Bakery and then reactivating Smart Crawl, the issue of speed persisted.

Please help, initially my client saw a tremendous increase in SERPs so we would really like to continue to use this plugin.

    • Zach
      • Not a Surfer

      Thank you Julian ,

      Glad to know I'm not alone. I also found out yesterday that the new SmartCrawl doesn't play well with Google Doc, Sheets, Slides, and Google Offline Documents browser extensions.

      ^^^ -I don't believe this is apart of my current problem, but adding it here just in case. Support helped me identify the extensions issue yesterday via Live Chat. Fortunately, I do not use these extensions and disabling them resolved the issue I had with a missing Refresh button in the Smart Crawl panel in post editor.

  • James Morris
    • WordPress Enthusiast

    Hello Zach

    I hope you are well today. Sorry for the inconvenience this has caused.

    A bug has been discovered and has been reported to our Dev Team to address ASAP. We will be publishing a hotfix release as soon as technically possible.

    Thank you for your patience while we sort through this issue.

    Best regards,

    James Morris

  • Zach
    • Not a Surfer

    Thanks for the update James Morris

    Please note, I was unable to restore with Snap Shot. Restoring from a point before the Smart Crawl update was futile as the Restore button didn't do anything, the site just sat there, no progress indication, nothing. Thank goodness hosting takes daily back-ups. I restored the site prior to the Smart Crawl update and very professionally looking, asked my clients to recreate their content. Honestly, the whole allure of Snap Shot was the ability to restore and keep content.

    What a mess... not sure if the bug in Smart Crawl affected Snap Shot, still testing.

    I have turned off auto update and will be installing all updates to staging first before I push to the site, a lesson learned the hard way I guess.

  • James Morris
    • WordPress Enthusiast

    Hello Zach

    I'm terribly sorry to hear you had the issue with Snapshot. It would be very good to know if there was a correlation between the two. If you need any assistance debugging please let us know.

    The hotfix release of SmartCrawl is now in QA and should be released very soon. We've identified that it had to do with the Page Analysis and Readability Statistics modules. If those are disabled, the error ceases. Our team has reworked those modules and are doing the final round of testing now.

    Thank you for your patience while we sort through this.

    Best regards,

    James Morris

  • Zach
    • Not a Surfer

    Hi James Morris

    I have installed the new update and the site functions good, well as good as it can on these damn GoDaddy servers.

    Anyways I was running the various scans and noticed the URL Crawler keeps timing out...
    "Your SEO crawl has timed out due to an unknown error. Please try again or contact support."

    Should I open a new ticket or can you take a look from here, Support Access is Granted.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.