Smart Crawl URL Crawler keeps timing out

I'm trying to run a new URL Crawl but the process times out right away, without not progress at all with the following error message: Your SEO crawl has timed out due to an unknown error. Please try again or contact support.

  • Dimitris

    Hello Zach,

    hope you're doing good today! :slight_smile:

    I just tried to run a new sitemap crawl and it seems that it's stuck on 27% at the moment...
    yourdomain.com/wp-admin/admin.php?page=wds_sitemap#tab_url_crawler

    Before starting this again, I increased the memory limits a bit more, even though there weren't any similar error message in debug log.

    I've also changed the automated schedule to run every day, instead of every week, so we can better monitor this.

    Please check above link after couple of hours and let us what was the outcome.
    Also, please spare one day, for the scheduled crawl triggers, just to see if this is some more generic issue.

    Looking forward for your results!
    Warm regards,
    Dimitris

  • Dimitris

    Hey there Zach

    I can truly see in SmartCrawl -> Sitemap -> URL Crawler
    /wp-admin/admin.php?page=wds_sitemap#tab_url_crawler
    that the crawl timed out, but I can see that last crawl was on April 11, 2018 8:01 PM.

    I presume that this was the scheduled scan that was completed successfully.
    Did you also get an email with latest URL crawler results? Please advise!

    As it seems that there's something related with the actual WP installation that does that, if scheduled crawler can complete successfully. In order to better test this, could you please create a staging environment of this installation? Meaning a complete and exact copy into another location/folder in the same server, using a separate database. In case you GoDaddy's Managed WP hosting, you can do this easily: https://godaddy.com/help/create-a-staging-site-16466

    Warm regards,
    Dimitris

    Warm regards,
    Dimitris

  • Zach

    Hi Dimitris

    I'm not sure if I received the email you are specifically citing. On Wednesday 4/11/18 at 1:45am PST I did receive an email from SmartCrawl but it was for the SEO Checkup. Perhaps this is the same scan?

    Reviewing SmartCrawl now I have not attempted to run the URL Crawler at all today yet arriving on the SmartCrawl -> Sitemap -> URL Crawler page the following error messages were present:

    Your SEO crawl has timed out due to an unknown error. Please try again or contact support.
    The crawl timed out

    I am not so sure the "Last crawl: April 12, 2018 3:05 PM" is accurate, but I will set up the staging site as you requested.

  • Dimitris

    Last SEO Checkup was on April 10, 2018 10:16 PM
    /wp-admin/admin.php?page=wds_checkup

    while last URL Crawler was on April 12, 2018 3:05 PM
    /wp-admin/admin.php?page=wds_sitemap#tab_url_crawler

    so the email should be from the SEO Checkup indeed.

    Please do proceed with the staging environment installation and send us some access details.
    As this is public forum, you should send us your details through our safe contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Dimitris"
    - WordPress admin (login url/username/password)
    - FTP credentials (host/username/password)
    - cPanel/Plesk credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.

    Warm regards,
    Dimitris

  • Zach

    Hi Dimitris

    Thank you for beinging your tests. Please note, this ticket was originally opened due to an issue I had with SmartCrawl and the Open Graph images it passed along to social media. This issue I believed was resolved through support chat at the time, which is why this ticket makes no mention of the issue.

    With the support staff member I chatted with, we had concluded the issue was due to the chosen theme passing along it's own og tags.

    The resolution was to always publish a post with a SmartCrawl OG image chosen along with the post's Featured Image selected. This would allow SmartCrawl's OG image tag to superceed the tag my theme was generating. However, if a publisher forgot to add the SmartCrawl OG image and published only with the Featured Image chosen, the theme's OG image tag would be all that was created and unfortunately this tag used a thumbnail that was too small to be used. (Facebook's debugger would regect the image). To remedy, the publisher is to remove the Featured Image and add the SmartCrawl OG image and update. Then add the Featured Image and update. This will allow the SmartCrawl OG image to again superceed the og image tag my theme is creating.

    Upon testing, this theory panned out, which is why I am only now bringing it up. You're about to do some testing on the staging site to review SmartCrawl and today I have realized, while the solution gets me by, it is in fact not the complete solution, my friend you have a bug.

    Since my chat with the support staff member, I have located the section in my theme which allows me to turn off it's OG tag generator (next to this option the theme even recommends turning it off if the use of a plugin such as Yoast SEO or similar is in use). Hazza! You might say, but much to the discouragement of the support staff member's theory, this option was set to disable my theme's OG tags.

    So I flicked on the theme's OG tags just to see what would happen. Sure enough new OG tags appeared in my header but what was interesting, I noticed these new tags actually pulled in an acceptable image. One that was 200x200px (the issue which prompted my inquiry was that the OG image tag was pulling in an image that was 180x180px, which Facebook wouldn't allow... it was too small, 200x200px is the minimum).

    Ok so now I know, my theme does produce OG tags (if I permit it) and that such tags are acceptable. Then I realized the placement of my theme's tags. They were at the top without comments referencing their function, while scrolling further down I see the SmartCrawl SEO comment followed by the section of OG tags it was introducing. And within the SmartCrawl SEO section of the code was the unacceptable 180x180px image and a seperate OG image tag referencing the full size image. This lead me to eliminate my theme's OG tags from consideration and I decided to trouble shoot SmartCrawl further.

    So with my theme's OG tags turned off I began adding images to posts to test. I found that if a post is originally published with a SmartCrawl OG image chosen and a Featured Image, the correct image is passed along while social sharing BUT an incorrect OG tag is also present (incorrect = 180x180px image used). However, if only the Featured Image is added to a post upon initial publishing, SmartCrawl automatically picks up (what I have identified in WP Smush's settings page) the post-thumbnail image (its also worth mentioning that on the WP Smush settings page you can easily identify which image dimensions are coming from my theme and not appart of WP core, the theme's name prefixes these dimension).

    So now the bug I've identified. If a SmartCrawl OG image is not specified in the Social tab of the SmartCrawl panel in a post's editor screen, SmartCrawl defaults to creating an OG image tag using the Featured Image at post-thumbnail dimension, which is now too small for use on Social platforms.

    Since Dimitris you have begun running test on the function of the SmartCrawl URL Crawler timing out, perhaps you can also verify my findings? Perhaps these issues are somehow linked?

  • Nastia

    Hello Zach

    Hope all is well!

    I've tested the SmartCrawl with Twenty Seventeen theme and could not replicate the issue; the og image size was unchanged, the original image was set and no other images with dimensions 180x180 were added.

    SmartCrawl adds automatically the feature image as og:image, so when featured image is added, there is no need to add OG image, unless it is a different one.

    Would you please run the following test?
    - Deactivate all the plugins, and see if the theme creating og:image with 180x180demensions
    - If no og tag was created, please activate SmartCrawl plugin and check if you can replicate the issue.

    Please let us know how it went!

    Kind regards,
    Nastia

  • Zach

    Hi Nastia

    I must admit I'm a little disappointed with this response. I took the time to write you a detailed note to help troubleshoot a bug with SmartCrawl. This note is in direct response to James Farmer blog article regarding the shift at WPMU DEV in focusing on working with other drag and drop providers. The ONLY plugins installed on this site are WPMU DEV and WP Bakery, which WP Bakery is a plugin James specifically cited. Furthermore, you didn't do what I asked.

    I have already gone through the steps you cited with the support staff member via live chat. I also know SmartCrawl works great with twenty seventeen, but that's not my problem. Please take a deep breath and carefully re-read my note from April 14th.

    Lastly, I'm not sure what you guys are doing, but even if I were to oblige your request, I can no longer get into my staging site.. 503 error every time. WTF

  • Zach

    Ok Nastia and/or Dimitris

    I was finally able to get in, -not sure what was going on there but I'm in.

    Ok so on to your suggestion:
    -All Plugins disabled (except WPMU DEV Dashboard), Theme with OG tags disabled (as was the configuration when SmartCrawl was enabled)
    ----- Test Post: stagingsite/uncategorized/smartcrawl-og-image-test-featured-image-only/
    ----- Result: No OG tags present (well duh, no SmartCrawl and OG tags turned off in theme... makes sense)

    -All Plugins disabled (except WPMU DEV Dashboard), Theme with OG tags enabled (again, I wouldn't have this on if SmartCrawl was also enabled, but sure ok lets test)
    ----- Test Post: stagingsite/uncategorized/smartcrawl-og-image-test-featured-image-only-2
    ----- Result: `<meta property="og:title" content="SmartCrawl OG image test Featured Image only 2" />
    <meta property="og:description" content="" />
    <meta property="og:url" content="stagingsite/uncategorized/smartcrawl-og-image-test-featured-image-only-2/" />
    <meta http-equiv="x-dns-prefetch-control" content="on">` Well that's interesting NO og:image tag, perhaps because WP Bakery is disabled? Let's test

    -Only WP Bakery Plugin enabled (and WPMU DEV Dashboard), Theme with OG tags enabled:
    ----- Test Post: stagingsite/uncategorized/smartcrawl-og-image-test-featured-image-only-3/
    ----- Result: `<meta property="og:title" content="SmartCrawl OG image test Featured Image only 3" />
    <meta property="og:description" content="" />
    <meta property="og:image" content="stagingsite/wp-content/uploads/2018/04/OpenHouseApril1415-200x200.png" />
    <meta property="og:url" content="stagingsite/uncategorized/smartcrawl-og-image-test-featured-image-only-3/" />
    <meta http-equiv="x-dns-prefetch-control" content="on">` Hey there's the theme's OG image tag but wait it's pulling in an acceptable image 200x200px. Do I have to say it... ok I will, this was mentioned in my post on April 14th, which I'm sure you're aware of because you have taken a deep breath and re-read the post :slight_smile:

    -WP Bakery and SmartCrawl enabled (and WPMU DEV Dashboard), Theme with OG tags enabled, only a Featured Image:
    ----- Test Post: stagingsite/uncategorized/smartcrawl-og-image-test-featured-image-only-4/
    ----- Result: Theme OG tags: `<meta property="og:title" content="SmartCrawl OG image test Featured Image only 4" />
    <meta property="og:description" content="" />
    <meta property="og:image" content="stagingsite/wp-content/uploads/2018/04/sandylane4-200x200.jpg" />
    <meta property="og:url" content="stagingsite/uncategorized/smartcrawl-og-image-test-featured-image-only-4/" />
    <meta http-equiv="x-dns-prefetch-control" content="on">` Hey look at that NO change from the previous test...
    SmartCrawl OG tags: `<!-- SEO meta tags powered by SmartCrawl https://premium.wpmudev.org/project/smartcrawl-wordpress-seo/ -->
    <meta name="description" content="and so it continues" />
    <meta property="fb:app_id" content="APP_ID" />
    <meta property="og:image" content="stagingsite/wp-content/uploads/2018/04/sandylane4-180x180.jpg" />
    <meta property="og:title" content="SmartCrawl OG image test Featured Image only 4 | Pacific Sotheby's International Realty" />
    <meta property="og:description" content="and so it continues" />
    <script type="application/ld+json">[{"@context":"http:\/\/schema.org","@type":"WebSite","about":"Site Title","dateModified":"2018-04-16 17:06:08.000000","description":"Site Title","encoding":"UTF-8","headline":"Site Headline","inLanguage":"en-US","name":"Site Title","publisher":{"@type":"Organization","name":"Organization Name","sameAs":["https:\/\/facebook.com\/Name","https:\/\/instagram.com\/Name","https:\/\/www.linkedin.com\/company\/name\/","https:\/\/www.pinterest.com\/name\/","https:\/\/plus.google.com\/+CompanyName","https:\/\/www.youtube.com\/channel\/youtube"]},"url":"http:\/\/stagingsite"},{"@context":"http:\/\/schema.org","@type":"Article","author":{"@type":"Person","name":"Author","url":"http:\/\/stagingsite\/author\/authorname\/"},"commentCount":"0","dateModified":"2018-04-16T17:06:08","datePublished":"2018-04-16T17:06:08","description":"and so it continues","headline":"SmartCrawl OG image test Featured Image only 4 | Company ","image":{"@context":"http:\/\/schema.org","@type":"ImageObject","height":445,"url":"http:\/\/stagingsite\/wp-content\/uploads\/2018\/04\/sandylane4.jpg","width":700},"mainEntityOfPage":"http:\/\/stagingsite\/uncategorized\/smartcrawl-og-image-test-featured-image-only-4\/","name":"SmartCrawl OG image test Featured Image only 4","publisher":{"@type":"Organization","name":"Organization Name","sameAs":["https:\/\/facebook.com\/Name","https:\/\/instagram.com\/Name","https:\/\/www.linkedin.com\/company\/name\/","https:\/\/www.pinterest.com\/name\/","https:\/\/plus.google.com\/+CompanyName","https:\/\/www.youtube.com\/channel\/youtube"],"logo":{"@type":"ImageObject","url":"http:\/\/stagingsite\/wp-content\/uploads\/2018\/03\/Name_logo_blog2.jpg","height":60,"width":60}},"thumbnailUrl":"http:\/\/stagingsite.com\/wp-content\/uploads\/2018\/04\/sandylane4.jpg","url":"http:\/\/stagingsite.com\/uncategorized\/smartcrawl-og-image-test-featured-image-only-4\/"}]</script>
    <!-- /SEO -->` Well look at that, SMARTCRAWL introduces the 180x180px image, are we having dejavu?

    I'm ready to try your next test, let's get this bug fixed.

  • Dimitris

    Hello there Zach,

    hope you're doing good today! :slight_smile:

    As this thread started about the actual Sitemap Crawler, I'd prefer to focus on this issue first. If we narrow down that this is happening due to the OG:TAGS part, we could then carry on with that too. If not, then we should move this into a separate thread, as we're keen on having separate threads per issue.
    FYI I also tried to replicate this 180*180 image in a local site of mine, with no avail though.

    Now, back in the initial issue, I tried to deactivate everything and used only WPMUDEV Dashboard, SmartCrawl and TwentySeventeen theme. Then I initiated a new URL crawler, but it seems that it got timed-out again, in the same percentage as before (28%).
    I also now try to start a new crawl, but I get the "Your SEO crawl has timed out due to an unknown error. Please try again or contact support." message right away, so I've contacted our developers about it, so they could have a better look inside.

    Will keep you posted here, as soon as possible!
    Warm regards,
    Dimitris