Smartcrawl and Visual Composer not playing well together.

Smartcrawl and Visual Composer not playing well together. The metadata shows shortcodes on indexed pages.

  • Adam Czajczyk
    • Support Gorilla

    Hello JazzyDan

    I hope you're well today and thank you for your question!

    This is a known issue, related to most "builders" that are using shortcodes to build content layouts. We already got solution crafted for this and it should be released soon, if it passes all the tests so please make sure that you're keeping the plugin up to date and the issue should be solved with one of the nearest upcoming updates.

    Kind regards,
    Adam

    • JazzyDan
      • The Crimson Coder

      I use visual composer on all of my sites 40+ and this is the only site with an issue.
      Surely the metadata put in to the smart crawl box, would override anything else. As it does on all of my other sites.
      I have the same issue on this site if I switch to Yoast.

      • Adam Czajczyk
        • Support Gorilla

        Hi JazzyDan

        Well, I can't say much about how Yoast handles that but if it comes to SmartCrawl there certainly is that known issue. I realize that it might not necessarily show up on each and every site though I admit I'm not sure why that is.

        As I mentioned before, there should be a fixing release for that published soon so let's, please, give it a chance and if that doesn't help, we'll immediately "jump back" into it and investigate the case as it will prove that it's specific to the site and related to some other "under the hood" issue.

        Best regards,
        Adam

  • JazzyDan
    • The Crimson Coder

    Another broken update!!
    This one is completely messed up.
    The Metadata shown is completely different to what should be in place, and was in place before the update.
    See attached. Google Preview is what should be in place and what as in place before the update. The Meta Data boxes show what is now in place for my meta!
    Whats going on?

  • Adam Czajczyk
    • Support Gorilla

    Hello JazzyDan

    The data shown on a screenshot - do you mean it should be used with for some other post/page (so meta data is "mixed" within various posts)? Or is it that some parts of it has been lost? Did it change right after update or upon e.g. updating post/page?

    I'm asking because in order to be able to properly test it I just need to be sure what exactly has happened.

    Phlick

    Would you please start a separate ticket of your own about the issue? You're more than welcome to follow this one too, of course, but having a separate ticket would let us better inspect the case and provide better assistance to both of you.

    You can start a new ticket here:

    https://premium.wpmudev.org/hub/support/#wpmud-chat-pre-survey-modal-technical-support-item-support-ticket

    Best regards,
    Adam

  • JazzyDan
    • The Crimson Coder

    You would not believe how broken this plug-in is. And how many issues it has given me today. I have lost half a day fixing issues caused by this plug-in. It has completely broken the home page on my site. And added 5-10 seconds to the page load time. I have reverted back to the previous version. Not good at all!!!

    Amongst all the other issues it has given me. It is loading random meta data from random pages. So mixed Meta yes. Changed immediately after the recent update.

  • Predrag Dubajic
    • Support

    Hi JazzyDan,

    Can you try adding this define in your wp-config.php if you have SmartCrawl 2.2.2.6 installed and see if that improves the load time:
    define('SMARTCRAWL_FORCE_REWRITE_TITLE', true);

    About the issue on the meta being rewritten, I did a test on my site by updating from 2.2.2.5 to 2.2.2.6 but that didn't affect my meta, so I would like to as few things to see if I'm testing the same thing.

    The page from the above screenshot, that is your home page, is that correct?
    Are you using static page for homepage in Settings > Reading?
    The content that is now shown on that page, where did it come from, is that meta from a different page?

    Please advise so we can investigate this further.

    Best regards,
    Predrag

  • JazzyDan
    • The Crimson Coder

    I have downgraded to a previous version, and will not update any of my other sites. I super happy I only did 2 at. this point!
    So no requirement for me to update my wp-config file, which I've never done in the past.
    I supplied one of your colleagues the theme that I use, I can't use my live site for any more testing and potentially break anything else. So I suggest you set up your own testing site using this theme to try and resolve these horrendous bugs!
    Yes the screen grab is from the home page. And it does appear that the meta is being pulled from a different page. My sites are all set to static page for homepage.

  • Predrag Dubajic
    • Support

    Hi JazzyDan,

    Thanks for the additional info, we have our devs working hard on next release and doing multiple tests in order to get all the page builders working properly.

    I'm also doing some additional tests on my end based on your above info, in order to provide them with additional info and stuff to be checked.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.