SmartCrawl critically slowing down saving menus

When I edit the menu either from Appearance > Menu or from Customiser > Menus, when I add pages and hit save, the save never occurs. nav-menus.php hangs indefinitely. When I deactivate SmartCrawl Pro, the problem disappears

  • Patrick Freitas

    Hi Guy

    Sorry to hear that you are having problem.

    I had a close look in the the problem, I tried to replicate the issue, unfortunately it took a short waiting time to add all pages at once, but I had no big problem, however we did some testes and I would like to share the results.
    I configured my php.ini as same configuration that you've got.

    PHP: 5.6.36
    memory_limit : 256M
    WP_MAX_MEMORY_LIMIT: 256M

    Using those configuration I experienced a short waiting time to add all my pages on the same time and I could see that this wait time decreased a bit without the SmartCrawl Pro activated. However we tried others configurations for example PHP 7.0 and PHP 7.2 and memory limit increased and we got good results, everything worked as should do.

    I would suggest, if you don't mind please increase some points:

    Remember, please always use an staging website, if you can't please provide a full backup.

    1- Wouldn't you mind to update PHP version, from 5.6 to 7.0 or 7.2, you can ask the web hosting provider which version they work with. If you use cPanel you can log in in the cPanel > scroll down until Software > search for MultiPHP Manager > Select website > select the available PHP version, access the website and check if everything is running well.
    p.s in some host providers this steps can be different, I recommend first ask the host support to make sure if PHP 7 is available and all dependences installed.

    2 - Increase PHP memory -
    - Login to the FTP account or by cPanel, go to WordPress root folder.
    - Search for wp-config.php.
    - Select and edit.

    Above the /* That's all, stop editing! Happy blogging. */ you can past the codes:

    define('WP_MEMORY_LIMIT', '512M');
    define( 'WP_MAX_MEMORY_LIMIT', '512M' );

    Save it and try to add new pages on the menu with the SmartCrawl Pro activated.

    Please, let me know the results,
    Have a great day
    Patrick Freitas

    • Guy

      Hi Patrick,

      Thank you for looking at that installation for me. I unfortunately am stuck with PHP 5.6 on that domain as I have another installation of an office management system on a subdomain which only works with 5.6. I've tried to set them independently with MultiPHP through cPanel but this hasn't been successful for me.

      I have another installation of SmartCrawl Pro on a different domain where the nav-menus.php file also takes an excessively long time to process, which in fact is on PHP 7. I tested this with Katya and while the menu alteration did eventually save, this was after quite some time.

      I will increase the amount of PHP memory available through the wp-config and php.ini and see what effect this has. However this is a pretty new problem and I've not had this before recent updates.

      If you could offer any advice on how I can effectively assign two different domain/subdomains to two differing versions of PHP I'd be grateful and we can hopefully close out the ticket.

      EDIT: I've now changed the PHP version on the domain to 7.0.3 and increased the memory limit through wp-config and with SmartCrawl installed, this still takes at least 2+ minutes for the nav-menus.php to load and therefore save any changes to menus. I've deactivated the plugin for now, but support access is currently granted so feel free to activate and test at your own leisure.

  • Patrick Freitas

    Hi Guy

    You can try to define the php version using .htaccess file:

    AddHandler application/x-httpd-php7 .php

    AddHandler application/x-httpd-php71 .php

    However you can also enable debug mode on WordPress and check if any error can be found there, access the WordPress root folder search for wp-config.php click to edit and past the code right above /* That's all, stop editing! Happy blogging. */:

    // Turn debugging on
    define('WP_DEBUG', true);
    
    // Tell WordPress to log everything to /wp-content/debug.log
    define('WP_DEBUG_LOG', true);
    
    // Turn off the display of error messages on your site
    define('WP_DEBUG_DISPLAY', false);
    
    // For good measure, you can also add the follow code, which will hide errors from being displayed on-screen
    @ini_set('display_errors', 0);

    You can find a full article here: https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    This will create a debug.log in the wp-content, you can change the .log to .txt and attached the file here, we can check if there is any relevant information there.

    Please let me know the informations.
    Have a great day
    Patrick Freitas

  • Patrick Freitas

    Hi Guy,

    I'm sorry hear that you are having this problem just in the SmartCrawl Pro.
    When we tested on our website I copied all of the configuration from your SmartCrawl to make sure that I would get the same results, as I said, it sent a waiting time on low PHP memory, but in case you had increased the memory it should be fixed.
    However, I'll be forwarding to our Second Level Support, they will have a closer look in this problem and replay to you for any fix or test.

    Let us know If you have a further question,
    Have a great day,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.