Smartcrawl - Home Page Issues

Hi Guys,
I have installed smartcrawl on the site and for some reason it is not recognising the home page metadescription, either in the smartcrawl admin interface or the on page customisation.
We do have a slightly modified header on this site so the code to load this is: -

<meta name="description" content="<?php if(get_post_meta($post->ID, "product_description", true) !='' ) echo get_post_meta($post->ID, "product_description", true); else wp_title( '|', true, 'right' );?>" />

I'm guessing that this must be part of the problem, but am not sure how to hook your plugin into the later half of that code. Note that we have to "product_description" bit of code in there as we reuse a custom field on product pages as the metadescription.

Any advise on how to modify the above would be greatly appreciated, or I guess I could even go for a custom header in the product pages instead, if that makes life easier.

Cheers
Simon

  • Webxopt

    Ok, noob here! I now have: -

    <head>
    <meta charset="<?php bloginfo( 'charset' ); ?>" />
    <meta name="viewport" content="width=1000" />
    <link rel="shortcut icon" target="_blank" href="https://www.brenclosures.com.au/wp-content/themes/brenclosures/favicon.ico" />
    <?php do_action('wp_head') ; ?>
    <?php apply_filters ('wp_title' , '|', true, 'right' ) ; ?>
    <title><?php wp_title( '|', true, 'right' ); ?></title>
    <link rel="profile" target="_blank" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="<?php bloginfo( 'pingback_url' ); ?>" />
    <?php // Loads HTML5 JavaScript file to add support for HTML5 elements in older IE versions. ?>
    <!--[if lt IE 9]>
    <script src="<?php echo get_template_directory_uri(); ?>/js/html5.js" type="text/javascript"></script>
    <![endif]-->
    <?php wp_head(); ?>
    </head>

    This has given me: -
    - 2 meta-descriptions - Both of these are the same, but neither of which are from the Smartcrawl Meta Description box
    - 1 title - which doesn't correspond to the one on the page - but adds a load to it. (On admin page "B&R Enclosures - Electrical Enclosures, Racks and Cabinets NZ", meta description "B&R Enclosures - Electrical Enclosures, Racks and Cabinets NZB&R Enclosures New Zealand | Electrical Enclosures, Racks and Cabinets")When you say "// code here" what exactly do you mean?

    I have tried lots of different combinations of you code, inside title tags, outside, with parameters, without parameters etc all with no luck.

    Any help would be much appreciated.

    Thanks
    Simon

  • Jude

    Hey Webxopt

    Sorry about the extreme delay here, I'd like to run some tests on the site. Can you please send in

    Subject: "Attn: Jude "
    - WordPress super admin/ admin username + password
    - FTP credentials (host/username/password)
    - cPanel details

    - link back to this thread for reference

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.