Smartcrawl option not showing up on posts for client

I am trying to setup Smartcrawl for a client of mine. When I "switch to" him under "Users", I see the Smartcrawl in the top admin bar but when I click on it, it doesn't allow me access.

It's also not showing up in the Posts. I can see it when I'm playing the role of Super Admin but not when I'm switched to my clients view.

FYI - I'm using Adminimize to show/hide specific items in the dashboard.

I've also gone to my Network Admin and configured the settings to show Smartcrawl to "Authors", which is the role I have my client set too.

I have granted support access to my site. The site/client in question is Adair Coaching.

    Adam Czajczyk

    Hello Matt,

    I hope you're well today and thank you for your question!

    The "SmartCrawl" link in toolbar shouldn't even show up for "Author" and it returns permission error because it leads to the SmartCrawl "wizard" and and SmartCrawl settings are set to be available only to super-admins (on "Network Admin -> SmartCrawl -> Settings" page).

    I reviewed the site and must say I'm not quite sure why it got there in first place. The second issue is that SEO options don't show up under the post editor and they should be there for author with your current settings. I tried to replicate both issues on my end but I wasn't able to even with Adminimize and Ultimate Branding in place

    Let's then please start with that second issue. Could you please try to switch that users site to a Twenty Sixteen or Twenty Seventeen theme temporarily to see if those options show up?

    Would that be possible to run a full plugin conflict test on site?

    Let me know please.

    Kind regards,
    Adam