[SmartCrawl Pro] Importing from ALl in one SEO

Hello,

I imported settings from AIO SEO and (almost) everything went well! This is great because I was able to import work done on AIO previously. I'm running through a unique situation and I'm hoping you can help me out with maybe a code snippet or something to resolve this. My pages are optimized with SmartCrawl. Blog posts are with AIO SEO. When I import from AIO, the meta data of blog posts is migrated on to SC. Issue is with the pages. The ones that already have data in them end up being blank, because I guess there is no data to import for the pages from AIO SEO. Is there a way it can import only when it is blank, and if content already exists in SC to skip over that? I'm really really hoping you guys can help me with that.

Best regards,
Paul

  • James Morris
    • WordPress Enthusiast

    Hello Paul

    I'm going to flag this issue for our Dev Team to get their feedback on this issue. If there is a hook or filter available, they'll let me know. If not, we'll move this over to a Feature Request so they can make this improvement to the plugin. This may take a little time to investigate and test out properly. Thank you for your patience while we sort through this issue for you.

    Best regards,

    James Morris

  • Paul
    • The Incredible Plugin Injector

    Hello James Morris ,

    Thanks for getting back to me. I really appreciate you guys trying to work this out for me, and future users :slight_smile:

    I don't mean to be pushy, but I'm having an issue with the sitemap while running both plugins, so I have to sacrifice one of them. It might have to be SmartCrawl since more work is put into the AIO SEO (due to having thousands of blog posts).

    I really don't want to remove SC and keep AIO SEO. Not a big fan of their product.

    But my main concern is the issue with the sitemap that I need to resolve. Please please please please please I really need to get this working. I cannot have a blank sitemap due to this conflict between both plugins, and I can't not include posts in the sitemap (workaround).

    I really appreciate you escalating this issue as you mentioned and taking this seriously.

    Really hoping on having a solution.

    Best regards,

    Paul

  • Paul
    • The Incredible Plugin Injector

    Hello Ash , James Morris ,

    Any updates on this? I remember a conversation a few months ago with James Farmer in regards to this, and he thought it was a great idea and that it would be done :slight_smile: I was really excited when I saw the notification pop up on the site (yes I know, it is very rare people get excited over notifications! lol)

    Right now I'm still stuck because I need to merge both data... otherwise, my sitemap is incomplete and more problems arise.

    Is this something that you can help me with? Is this something I would have to pay for?

    Please help me get this resolved.

    Thank you.

    Best regards,

    Paul

  • James Morris
    • WordPress Enthusiast

    Hello Paul

    I'm terribly sorry for the delay. I've checked the task and I can see that it's marked as "In Development" which means our Dev Team is actively working on the issue. I'm afraid I do not have much more details at this moment, nor can I provide an ETA on when this will be available. But I can assure you our team is working on this.

    Best regards,

    James Morris

    • Ash
      • WordPress Hacker

      Hello Paul

      I am afraid we don't have any confirmed news. The current status is the devs are adding a new option to implement this feature which should be done very soon. I want to ensure you that this is not ignored at all, rather it will come as a new feature. Though I don't have any ETA, I recommend keeping an eye on the changelog when next update is pushed :slight_smile: Thank you so much for your patience.

      Have a nice day!

      Cheers,
      Ash

  • Nithin
    • Support Wizard

    Hi Paul,

    Hope you are doing good today. :slight_smile:

    This feature has already made into the current release, you should be able to notice "Advanced" option, in the Import section, which once clicked should allow to keep the existing datas without deleting it during an import.

    Please check, and let us know if you have any further query. Have a nice day ahead. :slight_smile:

    Regards,
    Nithin

    • Paul
      • The Incredible Plugin Injector

      Nithin.... This is AWESOME!

      Just one thing though, I"m getting an error when doing the import. I'm only keeping the POST META option on as well as KEEP EXISTING DATA option.

      Can we go over this here or should I open a new ticket?

      Best regards,

      Paul

  • Nithin
    • Support Wizard

    Hi Paul,

    Extremely sorry for the delay in getting back to you. I gave a quick test regarding this, and I could notice a similar anomalies regarding this.

    I'm bringing this into our developers attention, to check whether there is any settings, or steps that's being missed, or if there is any fix to get this working, if it's something specific to the plugin.

    Will keep you posted once I get further feedback regarding this from our developer asap. Have a nice day ahead. :slight_smile:

    Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Paul,

    Sorry for the delay in getting back to you, I'm afraid, this seems more like a compatibility issue with how the datas are imported in the latest update in All in one SEO plugin.

    Due to the latest update, I'm afraid, the Import in SmartCrawl is no longer compatible. As a workaround, I tried to upload the older version of AIOSEO plugin v 2.9, and tried a test import, but unfortunately that doesn't seem to help much, could notice the same error.

    I have already brought this into our developers attention, so that this could be looked upon closely. Will keep you posted once I get further feedback regarding this asap.

    Sorry for any inconvenience due to this.

    Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Paul,

    . I guess from here I won't have to submit a ticket?

    If you meant regarding this new bug, then you can follow up in this ticket, no need to create a new ticket.

    The bug has already been escalated, so we'll keep you updated via this ticket once we get further feedback regarding the status of the issue. Have a nice day ahead. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Paul,

    Sorry for the delay in getting back to you, this issue has been fixed in the current release of SmartCrawl. However, it seems like All in One SEO plugin has released a latest version which I'm afraid, would still bring the same issue, as the fix was correlated to the version number of AISEO plugin.

    However, we have incorporated a hook to resolve such factors in our release, by adding the following code in your system as mu-plugins, or inside functions.php file of your child theme:
    add_filter('wds-import-aioseop-data-exists', '__return_true');

    Which should make sure the import works fine, I tested in my system, and it works fine with the above code.

    You can check this article on how to implement as a mu-plugins:
    https://premium.wpmudev.org/manuals/wpmu-manual-2/using-mu-plugins/

    Please let us know if you have any further query. Have a great day ahead. :slight_smile:

    Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Paul,

    I guess I can now remove the code snippet and life is beautiful again?

    Glad to hear it worked. :slight_smile: Yes, you only need to keep the snippet during the process of import. Once done, you can remove it.

    Have a great weekend ahead. :slight_smile:

    Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.