[SmartCrawl Pro] No: 'noindex' detected in 'robots' meta tag

Hi, I have 200+ pages that are saying they cannot be indexed by Google. They are coming up with a error message saying: No: 'noindex' detected in 'robots' meta tag
11:27 am
How do I get rid of this?
I saw a response to a question about thissaying to delete the app and upload again which I have done. this has not corrected it and it has removed all of my Meta Data

  • Kasia Swiderska
    • Support nomad

    Hello Dom ,

    I'm sorry to hear about this issue on your site.

    Can you give me an example of a page where this is happening? I have checked the robots.txt on your site and it looks correctly, there is nothing that would prevent pages from indexing.
    I checked a couple of pages and there is also no meta tag that says "noindex" there.

    kind regards,
    Kasia

  • Dom
    • New Recruit

    Hi,

    I have just tested these three pages in Google Search Console and they all had an error stating: No: 'noindex' detected in 'robots' meta tag. These were the first 2 I tested as there are many more we need to be indexed.

    My search console says we have 30 days that have indexed and 222 that are not. We on purposely have some that should not index but not that many and these pages below should defiantly index

    https://switchaid.org/charity-telecoms/
    https://switchaid.org/charity-energy-rebate/
    https://switchaid.org/business-energy/

    Thanks for your help.

    Cheers
    Dom

  • Patrick Freitas
    • Staff

    Hi Dom

    How are you today?

    I can see your robots has User-agent: *, it shold allow Google Robots correctly.

    Please, check the following settings, if your page or any post type is defined to index and follow.


    If you are allowing Search Engine to read your site.

    If the issue persists, please, grant the support access and we can take a closer look.

    Support Access Guide
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Best Regards
    Patrick Freitas

  • Patrick Freitas
    • Staff

    Hi Dom

    Thank you for the support access.

    I checked and all settings are correct, it shouldn't cause such a problem.

    Wouldn't you mind please add my e-mail as an additional owner on Google Webmaster Tools for this property and I can run some more tests?

    I sent you the right e-mail address by e-mail.

    Let us know when you added it.
    Best Regards,
    Patrick Freitas

  • Patrick Freitas
    • Staff

    Hi Dom

    Hope you are doing well.

    Yes, thank you for the access, and sorry for the delay here.

    I made some tests and new research about this.

    When first time I checked it has 222 URL marked with the problem, I double checked your configuration and can see that everything is ok.

    I also checked with the developer and he confirmed that I covered all possible causes on WordPress.

    Since then I started to run some new tests and make a new research on what else can cause the problem, on some Google Forum some similar report.

    It is possible you had the noindex when Google crawled the URL, and Google can take months until running a new Crawl on the URL back.

    I checked today and can see the number of reported URL already decreased.

    As you can see from the latest report is from May, and is possible when Google runs the next Crawl the warning will be gone.

    I asked Google to validate the fix, it should force run a new Scan on site and check if all URLs are ok now.

    You can learn more about validation on.
    https://support.google.com/webmasters/answer/7440203?hl=en

    Please, keep eyes on the Webmaster tools and let us know when the validation is completed and if all warnings are gone.

    Best Regards,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.