[SmartCrawl Pro] Plugin Incompatibility

I have been using SmartCrawl for almost a year without any problems. Now, after the WordPress update, it breaks my site. Several of my posts are unable to load. I’ve gone through all of the plugins on my website disabling them one by one and Smart Crawl is the one that is causing the issue.

Here is a post that doesn’t load https://spencercoffman.com/killer-press-release/

I’m not sure why Smart Crawl is all of a sudden acting up. However, hopefully, you can take a look and fix the issue. Thank you!

  • Kris
    • Support

    Hi Spencer Coffman

    I’m sorry to hear that you are experiencing this issue.

    I was able to narrow this issue to SmartCrawl -> Advanced Tools -> Automatic Linking -> Link To -> Posts switch. When it is disabled post load ok.

    This could be some sort of new incompatibility after update of any other plugin or theme on your site. If any update was done.

    I could not replicate this issue on my test site with default theme like 2019.
    I also review your plugins section but I cannot see anything there which could cause this, apart from “Auto-hyperlink URLs” plugin, which I also test on my site and this issue was not replicated as well.

    Before I escalate this to our devSLS team are you able to make full site backup and then run full plugin and theme conflict test with SmartCrawl -> Automatic Linking -> Link To -> Posts still enabled and see does that help? This could track us plugin or theme where conflict exist.

    Please deactivate all plugins except SmartCrawl and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict. If there is no positive result, switch to default WordPress theme like 2019 and see if it works.

    Also as a temporary solution you can disable SmartCrawl -> Advanced Tools -> Automatic Linking -> Link To -> Posts.

    Please let us know about the results.

    Kind Regards,
    Kris

  • Spencer Coffman
    • WPMU DEV Initiate

    So if you disable the post linking within SmartCrawl then everything works as it should?

    If this is the case, please disable that function and I can keep everything else active. At least this way I will still be able to use all of my existing plugins, keep using SmartCrawl, and also have my posts load properly.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.