SmartCrawl Pro SEO checkup is not working.

SmartCrawl Pro SEO checkup is not working. It seems to be stuck at 7% for forever.

  • Predrag Dubajic

    Hi Alvin,

    It looks like something strange happened during the scan of your site, it seems like there was some kind of a hiccup between the reset attempt and scan timeout that's causing incorrect data when we check the status of the scan.

    Can you run another scan in two hours as that's the time for complete cooldown of the scan and after that we should be able to gather more info about what's going on.

    Let us know what happens when you start a new scan after 2 hours.

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello Alvin!

    Thanks for getting back to us and letting us know about it.

    I checked the site again using our WP Checkup but also some external "crawler simulators" (sites that attempt to simulate how bots see the site) and I had some mixed results.

    While our WP Chekcup was able to scan the site for performance it again have no results on SEO scan. The log (on our end) for the last scan - the one that you run - shows that the process was completed (even tho it doesn't necessarily mean that the site was fully scanned, it's just about the process itself) but crawled only one URL.

    When checking with other tools, they either cannot access the site too or they detect some redirects. That last issue can also be seen when checking the site with Chrome developer's tools: it does show there's one redirect (301 from /news to /news/) or two redirects (301 and 302) when accessing the site. Weirdly, I wasn't able to find the pattern why sometimes there's only one 301 redirect and sometimes one 301 and one 302 redirect. Furthermore, while 301 is a proper redirect, 302 is actually a status that is often used for redirects but should not be and it may be "fooling" crawlers.

    However, I admit I'm not entirely sure if this is affecting the scan. Are you aware of any redirects being set - e.g. via .htaccess or in cPanel - for the site? Did you try to disable Yoast temporarily while running SEO Scan? I'm asking about the latter one because it also has some redirect capability but also it's code may be interfering here.

    Let me know about redirects and please give the scan a try with Yoast disabled and let's see what happens then.

    Best regards,
    Adam

  • Alvin

    Hi Adam,

    Thanks for your input. I did what you suggested by disabling the other seo plugin but I get the same result, unable to crawl my site. Regarding the redirection, I am not really sure which one you mean by one redirect (301 from /news to /news/) or two redirects (301 and 302) when accessing the site. Maybe this is for canonical ? I have double check the .htaccess & cpanel regarding the redirection but I don't see any redirection for the part you mention. The only redirection in .htaccess files is the default created by wordpress. While in the cpanel, there is only one redirection for this domain & that redirection has nothing to do with any of this.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /news/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /news/index.php [L]
    </IfModule>

    # END WordPress
    This is from my cpanel for this domain biketrader.com.my
    /mobile/bikeIndex.php redirect too https://www.biketrader.com.my/ permanent
    Am I the only one facing this kind of issue using this plugin ?