[SmartCrawl Pro] SEO CHECKUP never ends

We are setting up the Smart Crawl.
It says that:
SmartCrawl is performing a full SEO checkup which will take a few moments. You can close this page if you need to, we’ll let you know when it’s complete.

However, it has been over 30 hours.
The progress is always 100% with a "busy" icon in front of it.
It that normal? How much time should it take normally?

Look forward to hearing from you soon.

Best regards,
Ken

  • Adam Czajczyk

    Hello Ken

    I hope you're well today and thank you for your question!

    I have checked that on my end and it seem that the SEO Crawl has timed out, indeed. I have restarted it from my end and it is now showing me that it did complete fully. Would you please check how does it look in your site's back-end now?

    The "100%" stuck progress bar - just ignore it now, please. Leave that page and access crawl again and you should see a report there.

    Also, do you have any security (except Defender) tools installed on site and/or any caching (except Hummingbird) plugins there? If yes, it might be good to clear the caches as this might have interfered.

    Kind regards,
    Adam

  • Ken

    Hello Adam,

    Thanks for your help.
    1. It does show the result in the Hub on wpmudev.org. And we also received an email with report.
    2. It is still "In Progress" in the wordpress plugin panel.

    Before the WPMU plugins installed, we have SG optimization and Cloudflare installed and enabled.
    However, we have already cleared those caches and deactivated / deleted those plugins already.

    So what shall we do now?
    Do you think we need to wait some more time for the cache to be cleared successfully?
    Look forward to hearing from you soon.

    Best regards,
    Ken

  • Adam Czajczyk

    Hello @Ken!

    Thank you for your response.

    If you had SGOptimizer installed but you removed that, there's a good chance that the cache (and it's quite "aggressive") might still be enabled. I didn't notice before that you're hosting with SiteGround, I'm sorry about that. SiteGround might need some "additional tweaking" so would you please access your SiteGround's cPanel?

    You should see and "SGOPtimize" icon there so please access it. I think you will find there that there are still caches active, probably "static", "dynamic" and "memcached". Since you are using Hummingbird with Asset Optimization and Page Caching, please make sure that all these caches are flushed and then disabled.

    Once that's done, go to "Hummingbird -> Dashboard" and use "clear cache" button there and let's see if that helps.

    Those caches on SiteGround server, when Hummingbird is in use, should for now be disabled as they may cause other issues. We're working on a special "compatibility layer" for that but as for now, it's better to switch them off.

    Best regards,
    Adam

    • Ken

      Thanks Adam,

      We have flushed the cache and disabled the SG SuperCache functions.
      Now the website loads slowly, I assume it is because the website needs to be re-cached by WPMU again.
      The SmartCrawl now will not stop at 100% progress bar, but instead, it ends up with an error:
      "There was an error crawling https://www.mandarinduck.net/, we weren't able to get meaningful results"

      At the same time, the cache page of WPMU is not able to be accessed any longer. It keeps loading and ends up with an error 504, gateway time-out.

      BTW, we also have Cloudflare enabled and connected via WPMU plugin. Is this okay?

      Any suggestions would be helpful.
      Look forward to hearing from you soon.

      Best regards,
      Ken

  • Adam Czajczyk

    Hello Ken

    It might indeed need to be "re-cached" to get faster or, it's - unfortunatelly - possible, issues due to SG server-side caching are already there, they just were not "visible" when the cash was enabled.

    The CloudFlare, especially if connected via Hummingbird, is perfectly fine.

    However, we might need to temporarily put it in a "dev" mode during troubleshooting but we'll see about that yet. That being said, I think it's time for me to take a closer look at the issue. I would like to start with accessing your site and checking it so would you please enable support access to it?

    To do this: go to the "WPMU DEV -> Support" page in your site's back-end, click on "Grant Support Access" button there and let me know here when it's active.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.