[SmartCrawl Pro] Sitemap Blank

When trying to preview the sitemap it is blank. Support is enabled.

  • viobru

    Hi, Shawn!

    Thanks for contacting us, hope you are doing great :slight_smile:

    I checked the sitemap and I see an error logged in the console:
    Unsafe attempt to load URL https://h****y.com/wp-content/plugins/wpmu-dev-seo/includes/admin/templates/xsl/xml-sitemap.xsl from frame with URL http://h****y.com/sitemap.xml. Domains, protocols and ports must match.

    As Jack Alltrade mentioned, the content of the sitemap is visible if checking the source code: view-source from http://h****y.com/sitemap.xml and seems that the issue is caused because the site is trying to load the XSL file (the style sheet of the sitemap) from the "http" version of the sitemap file. If you check the sitemap on the "https" version of it you'll see that it loads fine: https://h****y.com/sitemap.xml, so all the XML code is there on the http version of the site map but it's just not being displayed to humans because the XSL didn't load. I checked it and I see that the site has the "http" URL set on the Settings > General > Site URL and Home URL. Could you please change that to "https" and then re-save the SEO sitemap settings and check if this fixes the issue?

    Please, make sure you have a COMPLETE and UPDATED BACKUP of your site before applying any change, just in case, and let us know if the issue is still there after applying the change.

    On the other hand, there is another option to "fix" this and it just consists in deactivating the style sheet assigned to the sitemap from SmartCrawl > Sitemap > Advanced. As you can see, I gave it a try and the sitemap was directly displayed, with no style applied, though.
    Have a nice day!

    Thanks!
    Violeta

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.