[SmartCrawl Pro] Sitemap gives ERROR 404

Hello,

Some of my sites running on Nginx are not creating sitemap and there for return ERROR 404.

Before wpmudev support recomended I put this code in:

# wpmudev smartCrawl

rewrite ^/(.*/)?sitemap.xml /wp-content/uploads/sitemap.xml last;

How to fix ?

  • Adam Czajczyk
    • Support Gorilla

    Hello Axel Axelsson

    I hope you’re well today and thank you for your question!

    If the site is powered by NGINX a redirect rule should be added to the NGINX conf file inside “location” block for the domain and the NGINX server must be restarted to apply the changes.

    I know however that on some hosts (most, in fact) there’s no access to nginx conf files so you might actually have to turn to the host support and ask them to add redirects for you. I’m assuming that the sites you’re referring to are not site’s hosted with us (WPMU DEV Hosting) is that right?

    Or you have tried to add that redirect already and it doesn’t help?

    Best regards,

    Adam

  • Axel Axelsson
    • Icelandic Viking

    Hello Adam,

    This website is on my own server so I have access to all. I have same Nginx script and setup on all but on some sites sitemap is not working. Some sites have worked so far but now it’s not working.

    Smells like bug in Smart Crawl Pro . . .

  • Adam Czajczyk
    • Support Gorilla

    Hello Axel Axelsson

    Thank you for response!

    If it’s your own server then yes you should be in total control of it but if the same nginx config is applied to all sites and it’s working for some of them but for some it’s not, I’d tend to say it’s somehow related to these specific sites. I’m not ruling out possible SmartCrawl bug yet but if there is one, it’d be something that “reveals itself” in a specific configuration/environment.

    Could you please enable support access to one of the affected sites and possibly one of those that are working fine so I could take a closer look? To enable support access, please go to the “WPMU DEV -> Support -> Support Access” page in the back-end of each of these sites and click on “Grant support access” button there, then let me know here once it’s done as I won’t be notified automatically.

    Let’s see if I can identify any reason for the issue. I might need to include our developers in the case (and for that I would need more “direct” access to the server) but let’s start with just support access and let me check this first, then we’ll see what to do next.

    Best regards,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Axel Axelsson

    It seems that support access is no longer active, most likely already expired as it’s time valid. Could you please enable it once again for me?

    I apologize for keeping you waiting but I was waiting to hear back from you. As I mentioned in my previous post – we don’t get any automated notifications of support access being granted so I didn’t know it’s open and ready for me to check.

    If you could please re-enable it, it would be great. Please confirm here once it’s done so I would know that I can proceed.

    Kind regards,

    Adam

  • Axel Axelsson
    • Icelandic Viking

    Hello Adam,

    Access open now.

    I got this error from wordpress:

    Error Details

    =============

    An error of type E_ERROR was caused in line 1129 of the file /var/www/clients/client0/web1/web/wp-content/plugins/wp-hummingbird/core/class-utils.php. Error message: Uncaught Error: Class ‘WP_Hummingbird’ not found in /var/www/clients/client0/web1/web/wp-content/plugins/wp-hummingbird/core/class-utils.php:1129

    Stack trace:

    #0 /var/www/clients/client0/web1/web/wp-content/plugins/wp-hummingbird/core/class-utils.php(1141): WP_Hummingbird_Utils::get_modules()

    #1 /var/www/clients/client0/web1/web/wp-content/plugins/bb-plugin/extensions/fl-builder-cache-helper/plugins/hummingbird.php(10): WP_Hummingbird_Utils::get_module(‘page_cache’:wink:

    #2 /var/www/clients/client0/web1/web/wp-includes/class-wp-hook.php(288): FLCacheClearHummingbird->run(Object(Plugin_Upgrader))

    #3 /var/www/clients/client0/web1/web/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)

    #4 /var/www/clients/client0/web1/web/wp-includes/plugin.php(465): WP_Hook->do_action(Array)

    #5 /var/www/clients/client0/web1/web/wp-admin/includes/class-plugin-upgrader.php(316): do_action(‘upgrader_proces…’, Object(Plugin_Upgrader), Array)

    #6 /var/www/clients/client0/web1/web/wp-admin/update.php(47): Plugin_Upgr

  • Adam Czajczyk
    • Support Gorilla

    Hi Axel Axelsson

    Thanks for enabling access!

    As for sitemap issue.

    I checked the site and I noticed the same 404 error shows up also if I try to access it directly. If not via suggested URL, it should load at least via

    domain.com/wp-content/uploads/sitemap.xml

    It does not in this case. Furthermore, I tried to install “File Manager” plugin on site (only temporarily) to take a look and check if the sitemap.xml file does physically exist where it should but that also returned “Installation failed: 504 Gateway Time-out 504 Gateway Time-out nginx/1.10.3” error.

    This, together with the Hummingbird error (which most likely is a result of failed install or update) suggests that there’s either something “blocking” writing to these folders on site (e.g. folder permissions) or there’s some error in nginx configuration that’s making it “too strick” if it comes to file access or – there’s not enough free space allocated for the site.

    That being said, could you please check about writing permissions for “wp-content” and its sub-folders and also make sure that there’s enough space on the server?

    Also, please check if the “sitemap.xml” file does physically exist in the /wp-content/uploads folder.

    As for Hummingbird

    This seems to be a consequence of a failed install or update (similarly to what happened when I tried to install other plugin). Could you please try updating the plugin manually? To do so:

    – being logged in to the WPMU DEV site, go to this page

    https://premium.wpmudev.org/project/wp-hummingbird/

    – download plugin’s installation .zip from there to your local drive

    – access your site via FTP

    – upload “wp-hummingbird” folder from inside the zip file to the “/wp-content/plugins” folder of your WordPress install, overwriting existing one

    – once that’s done clear all caches on site and server and see if you’re still receiving the error.

    Looking forward to hear back from you,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.