[SmartCrawl Pro] Sitemap not updating

I've updated my sitemap, added in the URL's that need to be crawled, run another crawl but still the sitemap is not updating.

Not sure why, but it looks like a glitch. Last sitemap.xml dates back to 2014.

Please advise what to to.

  • Adam Czajczyk
    • Support Gorilla

    Hello forgemedia

    I hope you're well today and thank you for your question!

    The issue here is an existing old sitemap created by the "Google XML Sitemap" plugin that you used to use on the site (it's still there but inactive). Apparently this plugin created a sitemap.xml file right in a root folder of your WordPress install.

    The files must be still there so it's overwriting the sitemap created by SmartCrawl. This happens because SmartCrawl puts the "physical file" in a /wp-content/uploads/ folder an only adds internal rewrite rules to WordPress.

    It's not a glitch or a bug as a good practice is that no plugin should create any additional file in a root folder of the WordPress install, unless absolutely necessary and there's no other way.

    To solve that, please access your WordPress install via FTP or cPanel "File Manager" and remove the "sitemap.xml" file from the root folder of the site install. By "root folder" I mean the one where you see /wp-admin, /wp-content and /wp-includes folders and wp-config.php file.

    Once this sitemap is removed, SmartCrawl's one should automatically be picked up. To make sure you might want to go to the "Dashboard" in the wp-admin area of your site and use "update sitemap" option in "SEO" box there, then clear caches on site.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.