[SmartCrawl Pro] Smart Crawl Seems to Not Work With Page Builders

I have prepared a video with the faults:
https://d.pr/v/mplno1

  • Nithin

    Hi marmoset,

    Hope you are doing good today. :slight_smile:

    Thanks for sharing the screencast, I do understand what you meant. Please do note that SEO analysis is more of a recommendation, and the plugin should be working fine.

    When it comes to page builders there could be instances where the plugin won't be able to pick such instances pointed in your video. Could you please enable support access to your website, so that I could give a closer look at the settings, and report it to our developers to see what further improvements could be done in such use case.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi marmoset,

    Hope you are doing good today. :slight_smile:

    Thanks for enabling support access. I just checked the mentioned page as shown in the video via the support access, and I could notice there aren't any such Page Analysis errors as noticed in the video for the mentioned page.

    However, I'm bringing this into our developer's attention regarding these observations noticed, and see what could be causing such reports in SEO Analysis.

    Will keep you updated once I get further feedback asap. Have a great weekend. :slight_smile:

    Regards,
    Nithin

  • Nithin

    Hi marmoset,

    Hope you are doing good today. :slight_smile:

    I got an update regarding the above query from our developer, for the issues noticed in /pilates-classes-bayside-melbourne/ page

    Regarding the images listed in the video, the SmartCrawl recommendations will only check for img tags, that's for example:
    <img src="path-to-image">

    In the mentioned video, the image was more of a background image added via CSS, and hence the recommendation was pointing no images.

    The First Paragraph has no keywords, and Content is shorter than 300 words are listed for the 1st paragraph.

    SmartCrawl checks via the HTML source code, there isn't any way to determine the visual changes done in the Elementor plugin by the page builders. So, the plugin would look for the 1st paragraph tag, ie the text enclosed for example:
    <p>text in here</p>

    In the mentioned page, the 1st paragraph is the "Small, personalised groups" text as shown in the following screenshot:

    Hence you were noticing the different results when compared visually, but how the SEO checkup would scan is code wise, and hence listing such analysis.

    I hope this clears your query. Please let us know if you need any further assistance. Have a nice day ahead. :slight_smile:

    Regards,
    Nithin

  • marmoset

    Hi thanks for getting back to me.
    This doesn't explain why Smart Crawl isn't picking up all text on the page.
    For example the main paragraphs of text are as below:
    <p><b>Pilates</b> (or the Pilates method) is a series of about 500 exercises inspired by calisthenics, yoga and ballet. <b>Pilates</b> <b>Classes</b> help you...

    Why isn't this getting indexed by the plugin?

    Also, SEO analysis from the plugin is saying 'no images found', wheraas there are 3 images on the page. Why is it not seeing these images?

    If this is a fundamental issue that Smart Crawl has with page builders then we wil need to re-evaluate whether we should use WPMU Dev at all - given that page builders are increasingly popular, and they are the only systen we now use in our agency.

    thanks

  • Nithin

    Hi marmoset,

    This doesn't explain why Smart Crawl isn't picking up all text on the page.
    For example the main paragraphs of text are as below:
    <p><b>Pilates</b> (or the Pilates method) is a series of about 500 exercises inspired by calisthenics, yoga and ballet. <b>Pilates</b> <b>Classes</b> help you...

    Why isn't this getting indexed by the plugin?

    Where exactly you are noticing this? Is this related to the following page?
    pilates-classes-bayside-melbourne/

    Please do share a screenshot so that we could have a better idea, and also please grant support staff access so that we could give a closer look.

    Also, SEO analysis from the plugin is saying 'no images found', wheraas there are 3 images on the page. Why is it not seeing these images?

    If the images are added via CSS by the Page Builder, the SEO analysis result won't pick such images. The SEO analysis is only for images added via img tag as mentioned in the previous reply. Images not implemented via img tag HTML structure:

    <img src="path-to-image">

    If the query is about /pilates-classes-bayside-melbourne/ page, then all the images are added via CSS in that page.

    If this is a fundamental issue that Smart Crawl has with page builders then we wil need to re-evaluate whether we should use WPMU Dev at all - given that page builders are increasingly popular, and they are the only systen we now use in our agency.

    This would be the same case with any SEO Page analysis test in general. I'm afraid, there isn't any way to detect the changes visible added by the Page Builders. The analysis works based on HTML structures added in a page, that's how SmartCrawl works at the moment too.

    I hope this brings more clarity. Please do advise if I have missed out anything so that we could give a closer look if needed.

    Please let us know once you enable access so that we could get the remaining questions sorted. Have a nice day. :slight_smile:

    Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.