[SmartCrawl Pro] SmartCrawl bug causes a timeout

Hi,
I have been experiencing a timeout and have just diagnosed it as being caused by Smartcrawl Pro.

All I do is go to WPAdmin->Appearance->Menus and try to edit a label of a menu item. When I click save the page takes forever and times out. When I deactivate Smartcrawl and try the exact same process all works perfectly once again. Then activating Smartcrawl Pro once more causes the timeout to reappear.

Here is what is found in my cpanel error logs:
Timeout waiting for output from CGI script /path/public_html/wp-admin/nav-menus.php, referer: https://subdomain.my-network.com/wp-admin/nav-menus.php

Not sure if this error was present before or after the recent update, as I am new to Smartcrawl.

If it helps my host is SiteGround and SmartcrawlPro is setup on a subdomain WPMS installation.

Please address this bug asap.

Thank you,
Dean

  • Dimitris
    • Support Star

    Hello Dean,

    hope you're doing good and thanks for reaching us! :slight_smile:

    This is already reported to us and it's being caused by the following setting in
    SmartCrawl -> Settings -> General Settings -> Builtin Modules
    - Page Analysis
    - Readability analysis

    Please try to deactivate these modules and check the response times when you're saving menus.

    I've already connected internally this thread with initial bug report, so me or another colleague of mine will keep you posted here, as soon as we've got some development on this.

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.