[SmartCrawl Pro] SmartCrawl Pro generated Sitemap.xml link doesn't work …

HI

I activated SmartCrawl Pro on my website. I run the Scan and configured the plugin for my website.

I have a problem: sitemap doesn't work. The scan work and everythings is ok( green) when i click on sitemap url , i have 404 page. i'm looking on my website files on the roots, i don't have the sitemap.xml .

  • Adam Czajczyk
    • Support Gorilla

    Hello leroy

    I hope you’re well today!

    SmartCrawl does not create any file in a root folder of your install. Sitemap file should be in /wp-content/uploads folder and SmartCrawl is adding internal redirect to WordPress to let you access it as it was in a root folder.

    On your site, however, it doesn’t seem to load from /wp-content/uploads directly too but from the site level I’m not able to tell if the file is really missing from there or if there’s some other issue (something blocking access to it, some additional redirect etc) causing it.

    There’s also still quite an outdated WP release and that can cause a lot of unexpected and difficult to diagnose issues. Is there any reason for not updating WP core? I would really recommend keeping WP and its all plugins up to date as this might solve this and other issues out of the box.

    Aside of that, please check if the “sitemap.xml” file physically exists in the “/wp-content/uploads” folder as this would at least tell us whether it’s an issue with a sitemap file creation or some “access” issue rather than this.

    Let me know, please.

    Kind regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.