[SmartCrawl Pro] SmartCrawl Setting for Social Featured Image

Using the Social Tab and Adding a Feature Image for Twitter post. I added many days ago images that displayed bad size on twitter. So I changed the images 2 days ago, but the previous images continues to show on tweets. How and Why is this happening. The pages I did this on are https://daytradersetups.com/tc2000-discounts.html and https://daytradersetups.com/tc2000.html
Thanks

  • Adam Czajczyk

    Hello Greg

    I hope you're having a nice day!

    The image that should be used for that first page is a ".....uploads/2017/02/TC2000off25.png" image, right? That's what I do see in page source code. If it's a different image that's used by Twitter, the most likely reason for this is Twitter cards cache.

    In a similar way to Facebook, Twitter bots do cache images they fetch. By default this cache should be - though I'm not 100% sure - refreshed about each 7 days but it might not always work. If you change image on site but the Twitter cache hasn't been refreshed, Twitter will not even fetch the new image but instead use the one it already stored in its cache.

    To solve that, make sure that once you change image for a post/page that's already been published, you also run it through Twitter Card Validator as this seems to be refreshing Twitter cache:

    https://cards-dev.twitter.com/validator

    Simply put the URL of such post/apge there and click on "Preview card". Additionally, if you got any cache on site/server, clear these caches before going there.

    This should solve the issue.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.