[Smartcrawl] Redirect 301 not working

I set up redirects 301on my site and they do not work. During the chat we try plugin and theme conflict - redirect still does not work.

What could be the issue here? I provided a staging site.

Thank you

  • Patrick Freitas

    Hi M.

    Sorry to hear that you are having this issue. I made a test on the stating site and removed the https from stating site, once this doesn't have on this site, and I it is able to redirect the link you can see on this example statingsite/our_products/organic-agave-inulin-powder/

    I activated all the plugins to try to replicate the problem but on the stating site I wasn't able.
    Was the plugin/theme test made on the stating on live site?

    Wouldn't you mind please to enable the debug on the live site? on wp-config.php
    above /* That's all, stop editing! Happy blogging. */ use the code:

    // Turn debugging on
    define('WP_DEBUG', true);
    
    // Tell WordPress to log everything to /wp-content/debug.log
    define('WP_DEBUG_LOG', true);
    
    // Turn off the display of error messages on your site
    define('WP_DEBUG_DISPLAY', false);
    
    // For good measure, you can also add the follow code, which will hide errors from being displayed on-screen
    @ini_set('display_errors', 0);

    Try to access any URL to redirect, then back to WordPress root folder/wp-content check for any debug.log, change it to debug.txt and attach on reply.

    Let me know the results.
    Best Regards,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.