SmartCrawl SEO checkup does not return any result

I have migrated the site to your host using Shipper. The SmartCrawl SEO checkup runs to 99% and then goes to the intial screen without showing any results.

  • Adam Czajczyk
    • Support Gorilla

    Hi Jeremy

    I hope you’re well today!

    I checked the site and it seems that the scan goes fine but “something” is interfering with showing its results. I see there are scheduled checkups though – can you tell me if you’re receiving e-mails with results for these checkups or they are not working for you as well (no emails or “empty” reports)?

    Will it be fine for you if I completely remove SmartCrawl from the site and re-install it (I’ll attempt to re-import its settings but I just need to ask as the site was migrated and I”m not sure how this will affect import)?

    Let me know, please.

    Kind regards,

    Adam

  • Jeremy
    • WPMU DEV Initiate

    Hi Adam,

    I have not been getting any emails from SmartCrawl at all.

    I’m happy for you to do what you need to with SmartCrawl as I haven’t put much time into setting it up just yet.

    I’m also getting similar issues with Humming Bird.

    Thanks,

    Jeremy

  • Adam Czajczyk
    • Support Gorilla

    Hi Jeremy

    Thank you for your response!

    As for SmartCrawl. I did some more tests and I didn’t try to “reset” it yet as I noticed some additional “weird” behavior (which I didn’t notice previously): if I clear all caches and run checkup again, it goes “slower” to the 99% and then seemingly “loops” admin-ajax requests that are handled (request -> response) directly by CloudFlare.

    Since the domain is directed through CloudFlare, could you temporarily put CloudFlare on “Pause” and check if the test then completes? This would be the steps:

    – login to you CloudFlare dashboard and select your domain

    – in “Overview” tab at the bottom of the right column there’ll be the “Pause CloudFlare” blue link so use it

    – then clear all caches on site (“Hummingbird -> Dashboard -> [Clear cache]”:wink: and Flush Cache on server (in “Tools” tab)

    – then try running SeoCheckup again

    After the test also, once you enable CloudFlare again, please connect CloudFlare to Hummingbird. There’s a form for this at the bottom of “Hummingbird -> Browser Caching” page.

    Let me know about results, please, and I’ll then proceed depending on that.

    Best regards,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Jeremy

    Thank you for testing that and keeping CloudFlare paused. If you could still keep it that way for a while it’ll be great.

    I did some more tests and discovered some unexpected behavior of the plugin, related to the outcome of a specific part of its code and resulting checkup data in the database. I’m not sure if that’s the culprit yet but I’ve asked our developers to check it too as it looks to me like it might be some sort of a glitch that happens in specific cases. But since that’s going up on a “development” level, I’ll need their expertise with it.

    I’ve passed the question to them and am awaiting their response. We’ll update you here as soon as we get to know more from them. Please make sure also that the support access is kept open on site (it’s time valid so it might expire on its own).

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.