[SmartCrawl] SEO Scan not going past 0%

Checkup in SmartCrawl is getting stuck at 0% and not proceeding. I have already tried running the test with all plugins except SmartCrawl (and WPMU DEV Dashboard) disabled and the theme switched to a default one, but that didn’t help.

When Query Monitor is enabled, it shows some errors (screenshot attached in ticket notes) when the checkup runs. My firewall logs also show some weird logs (examples attached in ticket notes). Please advice.

  • Adam Czajczyk
    • Support Gorilla

    Hi Vlad

    I hope you’re well today and thank you for your question!

    I checked your site and I can see the issue there. There are two things that are bothering me a bit and I’d like to start with sorting those out:

    1. The Query Monitor reports that there are Redis and Zend cache PHP extensions installed. That might mean that some opchache is actually actively used on server so if they are not “managed” directly from the WP in any way, they might interfere. Sometimes it’s possible to clear/disable (temporarily) them via some sort of server management panel so could you please check this? You might need to consult that with the host.

    2. The connection references in Query Monitor are also “weird” and since your firewall is reporting some issues as well this might as well be a connection issue. I’m not sure about the firewall that you are using but is there a way to white-list some IPs there? If so, could you try white-listing following IPs:

    66.135.60.59

    66.135.49.214

    66.135.60.64

    104.236.238.22

    104.236.50.140

    34.196.51.17

    52.57.5.20

    35.171.56.101

    Once they are white-listed, please clear caches again and see if it helped or not. If not, let me know please and I’ll investigate it further.

    Kind regards,

    Adam

  • Vlad
    • Flash Drive

    Hi Adam.

    Thx for the fast Reply.

    Well I did all that, plus I checked Smartcrawler just to see if it lies on my Hosting or on my install

    Even with ips whitelisted,…no result on main page. I ran conflict Tests on main site. No result.

    I also created,..a Fresh install on a subdomain,…Url crawler is not working, no pass over 0%. In one instance while chating with support,…url crawler ran for over 1h.

    Then I said,…ok,…it might be a Hosting issue. So I created a new site on a different Hosting,…Fresh install, no other plugin but the Dashboard plugin,…and also url crawler not passed 0%.

    What now?)))

  • Adam Czajczyk
    • Support Gorilla

    Hi Vlad

    Thank you very much for testing this all and getting back to me.

    I admit that’s quite surprising, I’d expect it to work at least at this clear setup on a new server. I myself am using Smartcrawl on my private site and have never had any issues with it so far but this is something that we’d definitely need to track down.

    I understand that this fresh setup is just a default WP install with only WPMU DEV Dashboard and SmartCrawl installed, right? Do you still got it? If it’s not a production site, I think it could be a good starting point for investigation. Would you be able to let us test it? It might involve some changes in its configuration or maybe even a server configuration but since it’s a test site it would be safe as it wouldn’t affect your production sites.

    If you could provide us with access details to it, that would be great.

    Note: Don’t leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: “Attn: Adam Czajczyk

    – Site login URL

    – WordPress admin username

    – WordPress admin password

    – FTP credentials (host/username/password)

    – cPanel credentials (host/username/password)

    – Folder path to site in question

    – Link back to this thread for reference

    – Any other relevant urls/info

    Best regards,

    Adam

  • Vlad
    • Flash Drive

    Hi Predrag. Thank you for your help. Ist true,…on one of the blanc test sites the url crawler is working fine. That would be the Domain starting with deal…

    However the other test site test2…..I still get a URL CRAWLER

    Your SEO crawl has timed out due to an unknown error. Please try again or contact support.

    The crawl timed out.

    And on the main site,…the main purpose of These entire Tests I only get a: Your SEO crawl has timed out due to an unknown error. Please try again or contact support.

    For info,…test2 and main site are located with the same Hosting. Both give Errors.

    What now,…cuz as far as I can see the issue is still there.

    What now?

  • Predrag Dubajic
    • Support

    Hi Vlad,

    I had started a crawl on your test2 site and it finished without any issues now, it might have been some caching that prevented fixed crawl to get to your site right away.

    Can you tell me what’s the other site in question and grant support access there as well?

    Best regards,

    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.