SmartCrawl sitemap shows 404 while adding nginx rules but works fine without those.

I try to add the rules for Hummingbird and Smush pro and when I add those, /sitemap.xml on the site shows 404 error or a blank page sometimes.

## WP Defender – Prevent information disclosure ### Turn off directory indexing

autoindex off;

# Deny access to htaccess and other hidden files

location ~ /. {

deny all;

}

# Deny access to wp-config.php file

location = /wp-config.php {

deny all;

}

# Deny access to revealing or potentially dangerous files in the /wp-content/ directory (including sub-folders)

location ~* ^/wp-content/.*.(txt|md|exe|sh|bak|inc|pot|po|mo|log|sql)$ {

deny all;

}

## WP Defender – End ##

# Enable Gzip compression

gzip on;

# Compression level (1-9)

gzip_comp_level 5;

# Don’t compress anything under 256 bytes

gzip_min_length 256;

# Compress output of these MIME-types

gzip_types

application/atom+xml

application/javascript

application/json

application/rss+xml

application/vnd.ms-fontobject

application/x-font-ttf

application/x-font-opentype

application/x-font-truetype

application/x-javascript

application/x-web-app-manifest+json

application/xhtml+xml

application/xml

font/eot

font/opentype

font/otf

image/svg+xml

image/x-icon

image/vnd.microsoft.icon

text/css

text/plain

text/javascript

text/x-component;

# Disable gzip for bad browsers

gzip_disable “MSIE [1-6].(?!.*SV1)”;

location ~* .(txt|xml|js)$ {

expires 9d;

}

location ~* .(css)$ {

expires 9d;

}

location ~* .(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac|eot|ttf|otf|woff|svg)$ {

expires 9d;

}

location ~* .(jpg|jpeg|png|gif|swf|webp)$ {

expires 9d;

}