[SmartCrawl] Sitemap URL not working

We activated sitemap in SmartCrawl, but the reported sitemap URL (/sitemap.xml) doesn’t show a sitemap, rather, it just shows a copy of the homepage. We are hosted with WordPress.com, not sure if that is an issue. Could you please take a look and see what’s up? I had WordPress.com support and asked them if they can add the following line to the Nginx configuration file but they refused:

rewrite ^/(.*/)?sitemap.xml /wp-content/uploads/sitemap.xml last;

However, the WordPress.com support has assured me that they’d like to cooperate to ensure that your plugins are compatible with their service if you contact them. Please advise.

  • Adam Czajczyk
    • Support Gorilla

    Hello Anthony

    I hope you’re well today and thank you for reaching out us!

    It seems that the SmartCrawl itself is working fine as the sitemap is properly generated and located where expected, at

    https:// your_site /wp-content/uploads/sitemap.xml

    At https:// your_site /sitemap.xml there’s currently a sitemap from Jetpack so first thing to check would be this:

    – disable Jetpack’s sitemap on “Jetpack -> Settings -> Traffic” page
    – once that’s done, go to “Settings -> Permalinks” page and re-save settings as they ara

    If that still doesn’t help, I’m afraid there’d be not much else to do. In general, SmartCrawl stores sitemap in /wp-content/uploads folder and attempts to add internal WP redirect. But if there’s either a physically existing sitemap.xml file at ‘domain.com/sitemap.xml” or there’s some other tool (plugins or redirect) overwriting that internal redirect or the server configuration is set in a way that overwrites such redirect then the only way would be to make host to change that.

    However, that being said, it’s actually not a requirement at all to host sitemap at ‘domain.com/sitemap.xml” URL. It’s perfectly fine to keep it in some subfolder as long as it can be opened in browser and access to it is not blocked for Google Crawlers (e.g. via ‘robots.txt’ file).

    It’s just a “custom” to keep it in root folder but you can as well simply submit the “domain.com/wp-content/uploads/sitemap.xml” URL to Google Search Console/Webmaster Tools and that should work equally fine.

    Best regards,
    Adam

  • Anthony
    • New Recruit

    Hi Adam,

    It appears that you have not had the full information passed on in this ticket, yesterday we went through almost 3 hours of testing with both wpmudev and with wordpress .com to get sitemap to correctly install on the site.

    Please see the following support transcript;

    Of course I know that jetpack is active we are unable to be without a sitemap and this is currently impacting our google listings.

    Please check the full transcripts of my conversation with your tech support person prior to taking an opinion that your plugin is working. It is not. I have got your team an opportunity to see the issue and to work directly with wordpress.com to fully test the issue within their environment and have given your support person full access to our site to see the problem.

    We enabled jetpack after finding your plugin was not generating a sitemap and gave extensive information to support so that they were able to investigate.

    It seams by this response none of it has been used :slight_frown:

    If it were a simple issue of another plugin being active I would not be having this conversation in the first place. Quite disappointing response given the detail and time the I spent yesterday coordinating the dialogue between wordpress.com and your support team.

    This ticket was raised by your support and appears inadequate to describe the nature of the actions that you need to take to resolve the issue.

    Please advise as to exactly the steps you have taken to investigate this matter properly.

    Regards
    Anthony

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.