SmartCrawl Url Crawler - timed out due to an unknown error

Hi,
in SmartCrawl > Url Crawler, I have warning: Your SEO crawl has timed out due to an unknown error. Please try again or contact support.

What does it mean? How to fix it?

Thanks,
Jiri

  • Jayman Pandya
    • Recruit

    Hi Jiri,

    I wanted to have a closer look at you site but the Support Staff Access was not open. Would you mind allowing the support access?

    To enable support access you can follow this guide here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please reply to this thread after you enable the Staff Support Access as we do not get a notification of it.

    Thank you
    Jayman

  • Jayman Pandya
    • Recruit

    Hi Jiri,

    Thank you for enabling the Support Staff Access. I looked and I got “Your SEO crawl has timed out due to an unknown error. Please try again or contact support.”

    I would like to dig in further to find the problem and help you resolve this. Can you activate the debug log by editing the wp-config.php and adding the following code just before /* That's all, stop editing! Happy blogging. */ in that file.

    /* Debug Settings */
    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);
    /* End of Debug Settings */

    Once you do this, try doing the URL Crawling again. If it fails then a log file named debug.log will be generated in wp-content folder. Please share that file with me by renaming “debug.log” to “debug.txt” attaching it to the thread. If the file is too big and cannot be attached, you can use services like Pastebin, DropBox etc.

    Looking forward to hear from you.

    Thank you
    Jayman

  • Jayman Pandya
    • Recruit

    Hi Jiri,

    I am sorry for the trouble. I see that you have enabled the debug logging on the site but still, it is not generated. There can be two reasons for it :?a) There were no errors.
    b) The code was added in wrong part of wp-config file.

    I tried running the URL Crawl again but was unable to which is why I feel there are some errors. Would you mind sharing the FTP access via our Contact Form so that I can dig in further and help you solve this?

    You can visit https://premium.wpmudev.org/contact/ and select “I have a different question” from the dropdown.

    Fill in your details and make sure to add “ATTN : Jayman Pandya” in the subject line. That way the request will be forwarded to me and I will be able to assist you on this. The access details can be written in the “Message” section of the form in the following format.

    - WordPress admin (login url/username/password)
    - FTP credentials (host/username/password/path of site in question)
    - cPanel/Plesk credentials (host/username/password)
    - link back to this thread for reference
    any other relevant urls

    Looking forward to hear from you.

    Thank you
    Jayman

  • Jayman Pandya
    • Recruit

    Hi Jiri,

    Thank you for the access. I was able to find the debug.log in web folder. I went through all the errors in the log and none of them are related to SmartCrawl.

    This points to the possibility of conflict with other plugins or theme. Can you do a quick plugin/theme conflict test as described in getting support manual E. Plugin Conflict Test.
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    *(make sure you have a backup before doing any changes!)*

    This should ideally help you find the cause of the problem.

    Please do write back with the results.

    Thank you
    Jayman

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.