SMTP connect() failed in ultimate branding

I used Ultimate Branding > SMTP > test email, it returns: SMTP connect() failed.
https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

I double-checked all data I set. I "allow Insecure SSL Certificates", it didn't work. I use my gmail account, any idea how to find out the exact problem and how to fix this?

  • Adam Czajczyk
    • Support Gorilla

    Hello kamhangmak

    I hope you're well today and thank you for your question!

    The issue here is related to how Google allows or not access to its accounts. If you don't have 2-factor authentication enabled on the account, all you'd need to do to make it work would be to go to this page

    https://myaccount.google.com/lesssecureapps

    (being logged into the account that you want to use) and enable the option to "Allow less secure apps". This is not really the Ultimate Branding setting but rather because of that the Google considers scripts that are trying to connect without full authentication as "less secure".

    However, if you do have 2-factor authentication enabled, this setting cannot be changed and you cannot "allow less secure apps". In such case it's still possible to use Google SMTP but it requires an access over their API. That means that you would have to create a Google App in Google Developers Console and provide the script with API credentials. Unfortunately, SMTP module in our plugin doesn't support that feature yet and while it is "on the list", I'm not able to give you any ETA or guarantee that it will be implemented anytime soon.

    To sum it up: if you're not using 2FA, use aforementioned "allow less secure apps" option and that should do the trick. If you are using 2FA I'm afraid that for now it would be best to find the plugin that does support Google API and will let you provide api credentials.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.