SMTP not working on Upfront form, but does work on SMTP plugin

I have a contact form using the Upfront builder, I have put my SMTP settings in but the email doesn't get delivered.
I have used WP-Mail-SMTP plugin and the test email works fine. I have disabled this plugin just in case they conflict
but it doesn't work. The settings are the same, any ideas?

  • Kasia Swiderska
    • Support nomad

    Hello Shaun,

    Could you update Upfront to the latest version and check if this will resolve this issue? (Please make sure you have a backup of your site).

    If that will not help, can you check if using WP-Mail-SMTP plugin and not using SMTP in contact form will deliver messages?
    Right now contact form showed me that my message was sent (it was from WPMUDEV). If this will not work after update can I test this form with my email address and SMTP? Let me know.

    kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello Shaun,

    Have you checked if on live server you are able to send emails (like registration, reset password) by using SMTP plugin and credentials you have?
    Because if those emails are working, then in contact form there should not be need use the SMTP - SMTP plugin will "catch" all the outgoing emails and handle them.

    I'm trying to establish here if this is malfunction of the contact form or there is more global problem with sending emails from site.

    kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello Shaun,

    Can you disable the SMPT plugin and configure SMTP in Contact form and enable debug.log in WP? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
    define('WP_DEBUG', true);
    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    After enablig it please try sending email again.

    I would need then to see content of the debug.log file - so please upload it to service like a Dropbox and paste link here.

    I'm testing this on my site and I'm getting inconsistent results that I need to investigate with developer. But I did test the Easy SMTP plugin with Contact form (that was configured to use wp_mail() and mail was sent correctly and delivered.

    kind regards
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.