[SMUSH] bulk smush does not work

Bulk Smush does not work on my site, re-check images show that some images need to be smush.
I tried plugin and theme conflict but the console still shows some errors 522.
After I disable Cloudflare errors are gone but still bulk smush does not work.
Please check ticket data.
Thank you

  • Nithin

    Hi Ralph,

    I gave a closer look regarding this, in general disabling thee Cloudflare should have resolved the issue noticed in your system.

    I could confirm .htaccess, and wp-config.php looks correct, but the issue still exists. This is really odd behaviour, could I know whether there is any server side cache enabled in your system?

    Could you also check whether switching PHP versions to the version from 7.3 to 7.2, brings any difference?

    I'm checking this with the developer regarding whether there is anything specific that could be causing this issue too. Will keep you posted once I get further feedback asap.

    Regards,
    Nithin

  • Nithin

    Hi Ralph,

    I checked this with the developer, and he was able to notice server-side cache when tested in your dashboard.

    Even when the Branda plugin was disabled, the dashboard theme didn't change:

    This could happen when there is a server-side cache enabled in the website, and that would explain the anomalies noticed with Smush too. Please do double check regarding this with your hosting provider, and check whether the cache could be disabled temporarily to ensure whether the issue still exists, or not.

    Regards,
    Nithin

    • Ralph

      Hi Nithin.

      After having changed to php 7.2, confirming with the host that no serverside cache was active and disabling Cloudflare, ther still was no improvement.
      The bulk smush is still not working..

      I have now reverted to php 7.3, enabled Cloudflare again just to try to salvage some page speed as it really is way low now.

      The Buløk Smush is still not working. Also Smush Cdn (I know it is in Beta) is not working, so the images are really causing the site to be slow..

      Any new ideas?

  • Dimitris

    Hello there Ralph,

    hope you're doing well today!

    I can no longer see the 522 error codes while on Smush page, but when checking for images we get some strange results:

    Image check complete, you have -34 images that need smushing. Bulk smush now!

    It seems that there're some broken thumbnails in your installation, could you please run the famous Regenerate Thumbnails plugin and try to "re-check images" in Bulk Smush once more?
    https://wordpress.org/plugins/regenerate-thumbnails/

    About Smush CDN, not sure what doesn't work, as I still see it enabled and website looks good to me. I may be missing something though, so please do let me know if that's the case.

    Warm regards,
    Dimitris

  • Pawel

    Hello Ralph!

    The issue with negative number of images sometimes comes from data being stuck in the OPCache, which I can see is enabled on your server. OPcache improves PHP performance by storing precompiled script bytecode in shared memory, thereby removing the need for PHP to load and parse scripts on each request. This may cause erroneous values to be sometimes reported and other issues.

    Are you able to flush that cache? There's often an option to do that in the hosting's administration panel/dashboard, but it depends on the hosting.

    There's also an option to disable the OPCache for the site if the server configuration allows that. You'll need to add the following at the beginning of your site's .htaccess file:

    php_flag opcache.enable Off

    If it causes a 500 Internal Server Error, you'll need to remove that - and it means your host doesn't allow overriding this value per site settings.

    Kind regards,
    Pawel

  • Pawel

    Hello Ralph!

    There is an option to disable OPCache, even on a shared server. You may want to try talking again with your hosting provider and send the this link which describes how to blacklist files from being cached:

    https://community.centminmod.com/threads/enable-disable-zend-opcache-per-vhosts.2621/#post-12257

    It's an easy solution and it doesn't require a lot of maintenance from the server administrators.

    Kind regards,
    Pawel

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.