Smush causing PHP Notice

When I activate Smush it causing the following PHP notice on the front-end of my site:

PHP Notice: Undefined index: rest_route in ***/wp-content/plugins/wp-smush-pro/core/modules/class-wp-smushit.php on line 1495

  • Ash
    • WordPress Hacker

    Hello Michel

    This is just a notice, which is not harmful to the website but helpful for the developer. You can disable debug mode to hide the notice.

    To disable debug mode please go to wp-config.php and change

    define( 'WP_DEBUG', true );

    to

    define( 'WP_DEBUG', false );

    Though, I have already informed the developer so that he can work on this and take proper steps so that this notice doesn’t appear. Hopefully, very soon this will be taken care of. We appreciate your patience on this.

    Have a nice day!

    Cheers,

    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.